Jump to content

eddieauguri

Members
  • Posts

    1
  • Joined

  • Last visited

Profile Information

  • Registered Products
    1

eddieauguri's Achievements

Newbie

Newbie (1/14)

  • Week One Done
  • One Month Later
  • First Post Rare
  • Conversation Starter Rare

Recent Badges

0

Reputation

  1. Howdy all, first time posting. I've had my Helix since about late 2018/early 2019. It has always worked without a problem for the past few years. Recently it started giving me the :-28 and :-33 errors. Of course these told me it was time to actually update the firmware since I hadn't done that since purchasing (bad idea, I'm aware. Haha). I got it updated and thought any freezing or failure to boot issues were resolved. But boy, was I wrong. The issues have since gotten worse with updating from 2.3 to 3.1 It has only properly booted once, and then it stopped working before I finished playing my first song for warmups. Since then, I reinstalled the 3.1 update and it has not helped. I either get the :-28 error and it never boots, I get the :-33 error and it doesn't boot and goes into update mode, or it just freezes before booting up. This most recent time trying again it actually booted to my first preset screen, but was frozen from there and wouldn't turn pedals on/off or go into tuning mode. Please help. Since purchasing this unit a few years ago I've since gotten rid of my entire set up and went all digital. I just want to practice my warmup songs and then play. Lmao
×
×
  • Create New...