Jump to content
Sign in to follow this  
edric1200

Amplifi 75 vibration

Recommended Posts

Hi i have an Amplifi 75 which has a bad vibration when playing the deeper notes ie sixth string and A string in places ,what is the best thing to do as i think i am still under the 5 year warranty do i send it back or try to fix the problem myself.

Share this post


Link to post
Share on other sites

Hi i have an Amplifi 75 which has a bad vibration when playing the deeper notes ie sixth string and A string in places ,what is the best thing to do as i think i am still under the 5 year warranty do i send it back or try to fix the problem myself.

If you are still under warranty I would go that route. Opening up Amplifi and tinkering around could potentially void that warranty. 

Share this post


Link to post
Share on other sites

Thanks for the reply,its a bit of a nobrainer really but if someone had said it was an easy fix maybe i would have had a go.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...