Jump to content

Helix Rack Recording Not Working in Logic X


Recommended Posts

Hi all,


New to the Helix Rack (upgrading from Pod X3), but I can't find any reference to this problem:

In Logic X, when trying to record via USB 1/2, when I enable tracks to record in Logic, the Helix Rack then starts flashing back and forth from the preset I'm in to the tuner. The flashing frequency coincides with the flashing of the record buttons on the tracks! Disabling the record stops the flashing, leaving the Helix in the tuner.


I'm using Core Audio with the Helix Rack selected as output and input device in Logic under Preferences->Audio.

I've tried using a different output device, but with the same results.

I've also tried it with the 1.0.5 Helix maxOs drivers installed AND uninstalled.


Recording in this way with my Pod X3 worked perfectly.


Firmware 2.71.0

Logic X 10.4.3

macOS 10.14.2


Thanks in advance!

Edited by dflateau
better topic
Link to comment
Share on other sites

I've got the rack unit, and Logic X.  Plan to do some recording, so your post caught my eye.


Unless there is some kind of problem with any of the components - seems when you arm to record, Logic is sending a MIDI message back to the Helix.  Since it's flashing the tuner, it should be CC#68 in there somewhere - the reserved number for the tuner on the Helix.  Since I'm not sure how to disarm outgoing MIDI messages on Logic (I'm sure it's buried in there somewhere), I think the first thing I would try is to turn off the Helix ability to receive MIDI messages via USB (Global Setting - MIDI over USB).  If that solves the problem - depending upon your needs, maybe you want other MIDI messages from Logic to Helix - I would then do the research into turning off, or controlling MIDI messages from Logic.


Just a first thought, please post what you discover so I'll know what to do when/if it occurs for me.


Edit:  I did some investigation - Logic has deep/wide MIDI activities going on, far more than I had thought.  I think initially shutting off Helix receiving them will tell the initial story.  Finding out the specific culprit in Logic - good luck with all that!

Edited by MikeDV1
More info.
  • Like 2
Link to comment
Share on other sites



Thanks for your reply! Sure enough, disabling MIDI over USB on the Helix fixed the problem. Now to fix the problem on the Logic side....


One thing I noticed is that the tuner flashing happens only when more than one track is record-enabled.


But I do found it odd that I'm the first to see this bug. Anyone from Line 6 have any thoughts?




Link to comment
Share on other sites

Very cool, feels good to figure one out.  I'm not sure it's a bug.  As I said, Logic uses extensive and complicated MIDI activities.  Whatever it was sending to the Helix was something that made it act cray cray - competing or multiple commands.  I've done lots of MIDI stuff with the Helix and a 1st generation Liquid Foot Pro MIDI foot controller, and it's always been tight.  As you said, some insight from the Line 6 folks would be good.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...