Jump to content

Relay G75 unresponsive


Recommended Posts

Hi guys, 

I just received my G75 and I'm trying to get it set up. 


I followed the instructions in the manual and connected the receiver and transmitter up properly. However, when I turn on the G75 it flashes up with the Line 6 logo and then the screen goes black. 


I tried updating it to the latest firmware but the update keeps failing. I updated the firmware on the transmitter and it worked fine. 


Is my G75 dead out of the box or am I just missing something blindingly obvious? 



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...