Jump to content
Sign in to follow this  
OskarikoponenEW

Helix LT 2.80 update problems

Recommended Posts

Hello, I'm not sure should I be worried. Just got my Helix LT and I started update it from 2.30 to 2.80 and the updater got jammed in somepoint at the middle and has been frozen for like 1 hour now. I don't want to shut down the program, so I don't lollipop up anything, but not sure if I should try like different USB-port or something. Pls helpUpdatefailure.png.90b1b5c977ddbcd381a71c80e8140ec6.png

Share this post


Link to post
Share on other sites
9 minutes ago, OskarikoponenEW said:

Still here in a same situation 

 

I think the reason you have not gotten more response on this topic is that there are already so many other topics addressing this. Just scroll back through a couple of screens of posts sorted on most recent and you will find a lot of help and tips from others who have hit this problem and resolved it. There is also a sticky post at the top of the screen that has lots of help resolving this. Here's one of many out there to start you off:

 

 

Share this post


Link to post
Share on other sites

Alright, so I got some help from tech support and so far it has been good. So first of all, I had wrong version of HX edit (2.71). I updated it to 2.80, so that I got right drivers and software. After installing all software and drivers I turned Helix on and at same time pressing pedals 6 (MODE) and 12 (TAP/TUNER), that will make Helix go on update mode. After that I ran updates and now it is alive again!

 

Thank you tech support! <3 

Share this post


Link to post
Share on other sites

Right so - I deleted everything line 6 and just downloaded the new HX edit again and it updates everything including new drivers . I pulled everything from the computer ie interfaces etc and changed through the usb’s. Eventually found one did exactly the same as before and it is updating as we speak . All the usb sockets are the same ! I don’t get it

Share this post


Link to post
Share on other sites

Same here - I had to delete everything (backing up my backups from Edit) and just re-download from scratch. Funnily enough it was re-downloading HX Edit that did the trick. Weird.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...