Jump to content
Sign in to follow this  
kraftybob

Ext Amp Not Working Correctly w/DSL40C

Recommended Posts

Hello Everyone:

 

I have a Marshall DSL40C and it has a two button foot switch - Channel (tip) & Reverb (ring) and the plug is a TRS.  Using a TRS cable and setting the Helix to Ext Amp in global settings, I can only get the reverb to switch on/off but not the channel.  I've tried assigning the channel and reverb to foot switches and I also tried the instant command and I still cannot change the channel.  To test further I took a crappy TRS cable and swapped the tip and ring on one end and sure enough the channel now changes (but the reverb doesn't).  This makes sense because the ring on the Helix side is now connected to the tip on the amp side.  I also connected the Marshall foot switch again and it works as expected so I know it's not the amp.

 

It seems as if the tip connection inside the Helix is not working.  However, and this is the strange part, when I turn my amp on it's on the clean channel. As soon as I turn the Helix on it switches to the OD channel.  When I turn the Helix off, my amp switches back to the clean channel - so obviously there's some connection on the tip taking place.

 

I'm going to call Line 6 tomorrow, but wanted to check here as well to see if anyone ran into the same problem?

Share this post


Link to post
Share on other sites

Update.  I called Line 6 Support and they were not able to offer any help at this time.  He said they cannot guarantee that it would work with my amp, but I find it odd that the reverb works but not the channel.  I would expect it to be all or none.

 

Question: Is anyone else here using the Helix LT with a Marshall DSL40C (not CR) and able to change both the channel and reverb with the Ext Amp connection?

 

Additional Info: when my TRS cable is plugged into the Helix and I check the voltage I get unusual readings:

Tip On: 3.26v

Tip Off: 3.26v

Ring On: 3.5mv

Ring Off: 2.0mv

 

Yes, you are reading that correctly - the Ring (which works) is in mv and changes voltage depending on the state of the switch. Where as the Tip is in volts and does not change state.  I asked Line 6 about this and he didn't have an answer.

 

I tested my TRS cable with a meter and it's good.  I also tried using a different TRS cable with the Helix and my amp and same results.

 

I am running v2.92, however, I ran into this issue in previous versions but thought maybe I was doing something wrong.  I didn't have a need for it at that time so I left it.  Now I'm creating some patches with my amp and would like to have this option.

 

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...