Jump to content
Penax

Amplifi 150 - Bass, Mid, Treble Error

Recommended Posts

Hello

The bass, mid, treble knobs stopped working for me.  And overall performance has dropped.

I have the latest firmware.

Share this post


Link to post
Share on other sites

Hey Penax,

 

Is it only the controls on the amp that failed or have the EQ parameters in the app failed too? If it is only the physical knobs, it may just be a small fault with the board of potentiometers, or maybe the wires, otherwise it may be something software-related if the app doesn't work either.

 

If the app works and the amp is out of warranty, try taking off the back and having a look. There is really sticky thermal paste and a heat sync so be careful not to get it all over your skin, but the whole dismantle process is very quick and easy.

 

I hope it is just a loose wire or something that you can fix easily.

 

Riley.

Share this post


Link to post
Share on other sites

Thank you for answer.

Yes, the EQ parameters can be set by the application.

The amplifier is not under warranty. I'll try to disassemble.

 

Share this post


Link to post
Share on other sites

It also has a long Line 6 Spider JAM.  This works without any problems.  I'm on a business trip now.  Then I look at Amplifi and check the electronics.  If I see anything there.

Share this post


Link to post
Share on other sites

No to tell the truth i never did do an update to it. Tech support has told me it has a definite hardware issue though and it will either need to be repaired or be replaced. Up until this, the amp was working great. You can hear the power supply turn on but get nothing from anything. Thanks for the reply!!! Hope no one else has this issue... P.S. This started when i hooked up my my FBV MKII controller to the amp, turned it on, and this is what happened. Did i do something wrong? Now gonna be a little frightened to try it again with a different amp... Anyone else have this issue?

 

FaceTime PC

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...