Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Firmware update Amplifi150 fails..death loop


Recommended Posts

Hi, I was playing my Amplifi150 and everything was fine.  I turned it off, turned it back on and I got 4 flashing lights so I googled it and found that there was a failed update.  I have repeatedly tried updating it on my computer via USB as everything else on the amp is not working now.  Any ideas on how to either hard factory reset or complete the install?  It seems to install the firmware but the process after where it must clean things up is failing.  I hope someone has experienced this and can share the fix.

Link to comment
Share on other sites

  • 4 months later...



I had the same situation but after reading a comment from the forum I solved the problem.


Put your AMPLIFi 75/150/TT into update mode by holding the Tone and Tap buttons while turning it on (for the FX100, hold the A and C buttons while powering up). Then, select the latest update from the AMPLIFi Utility app. Once the update is finished, you may be presented with instructions to perform a factory reset.

Link to comment
Share on other sites

  • 1 month later...

This is a touchy area. I bought a used 150 that came with version 2.5, and I wanted to update it, as well as reverting to the factory default presets. It failed spectacularly, even when trying to do it while a Line 6 tech talked me through repeated attempts on the phone. I'm very knowledgeable computer & hardware guy, and tried it with 3 separate desktops. It left me without a functioning amp, which had to be sent back to the factory to take care of it. Line 6 was gracious enough to make the upgrade at no charge, but it cost me over $110 to ship it to them. That sucked the heck out of the good buy that I got in selecting a used device...

Link to comment
Share on other sites

  • 2 months later...

It sounds like your AmpliFi 150 is experiencing a failed firmware update. Here are a few things you can try to resolve the issue:

  1. Hard reset: Try performing a hard reset on the AmpliFi 150 by pressing and holding the reset button for 15 seconds. This will restore the device to its factory default settings.

  2. Reinstall the firmware: Try to reinstall the firmware using a USB drive. Make sure you are using the latest firmware version that is available on the official website.

  3. Use the AmpliFi App: If you have the AmpliFi App installed on your mobile device, try using the app to update the firmware.

  4. Contact support: If none of the above solutions work, it is recommended that you contact AmpliFi support for further assistance. They may be able to provide more specific troubleshooting steps based on your specific device and firmware version.

It's also important to make sure that you are following the correct steps when updating the firmware and that the device is not losing power or connectivity during the process.

Keep in mind that a failed firmware update can also be caused by a power outage or a problem with the device's storage, so make sure to eliminate these possibilities. All Savers Provider Portal

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...