Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Apple Silicon Mac and Catalyst Edit issue


Recommended Posts

Today (my second day of Catalyst 100 ownership) the Catalyst Edit software on my M1 MacBook Pro would not see the amp.  The Mac's "Audio Midi Setup" saw the Catalyst as both a valid midi host and as audio input and output. The Edit software itself took a very long time to load whether the amp was connected or powered on or whatever.  


This was odd because yesterday, upon initial setup, everything worked as expected.  I was able to back up the default settings of the amp to my Mac, create new Presets and same them both to the Mac and the Catalyst.


I tried many things (new USB cable, reinstall of software, factory reset of amp).  No love.


The solution -

Go to Applications and find the "Catalyst Edit" app.

CTL, Click and select "Get Info".

Click to select the box labeled "Open using Rosetta".



Launch the app

It now works great!


Are we ready for the super odd part.  I can close the app, turn off the "Open using Rosetta" setting and it still works!  


Not to creep the scope of things too much in this thread, but...  Catalyst Edit was also not working on my iPad Air with Apple silicon over USB today.  However, after the above procedure, it also now works without any changes on that device. 


At any rate.  I hope my experience helps some unfortunate user of Apple silicon with this app.  






Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...