Jump to content
kutjaaa

Spider Valve MKI & Shortboard MKI

Recommended Posts

Hi All,

 

 

A have a Spider Valve MK I with Shortboard MKI! A have a problem with my shortboard, when I connected to the amp, it always going to the edit mode! I tested what happen, and I found an interesting thing. When I knocking on the controller's chassis with My finger it is go to the edit mode or blinking the led of the FX loop, if I touch the FX loop switch (no I not push, just touch ) when I do this same thing happen! Because this problem appeared before our concert I disconnected the cable from the pcb of the FX loop and UP switch as short term solution! But it is not comfortable! 

 

Do anyone have idea what is the problem, the solder looks like good and the switch works fine!

 

Regards,

kutjaaa

Share this post


Link to post
Share on other sites

First thing to try is a new cable, after that I would definitely blowout the holes for the cable where it goes into the amp and the board to make sure there's no debris which is what hinders its performance.Just make sure it's firing on all cylinders!

 

cgtrox

Share this post


Link to post
Share on other sites

Thanks for Your answer, I found how the rj45 hole in the amp side was unstable when the amp  is heated! I replaced this part and the problem is disappeared.

 

Regards,

Kutjaaa

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×