Jump to content

BlackFaceMao

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About BlackFaceMao

  • Rank
    Just Startin'

Profile Information

  • Registered Products
    1

Recent Profile Visitors

84 profile views
  1. BlackFaceMao

    Pod HD500X weird problem

    Thank you both for answering, I reset my POD without much hope and indeed, it did nothing. I think I'll keep my POD and repair it when I have the means to. It does seem like there is an internal problem with the switches but I didn't want to go to far into dismantling the device. Thanks again!
  2. BlackFaceMao

    Pod HD500X weird problem

    Hi, I came here hoping that someone might enlighten me about the problem I'm facing with my device. When I start my Pod, I can see on the screen that the arrow on the different effects on the preset goes all the way to the left. When I use the arrows to go right, it doesn't do anything as if I was holding the left arrow button. I tried to go into the settings and I/O but I can't navigate un the menu, since I need to go right to changes pages and when I try, it stays on the first page. I cleaned the buttons and checked to see if anything got stuck under the plastic but I found nothing. Also, I don't know if it's related to the pevious problem but my tap and loop switches are acting weird. When I hold the tap button the start the tuner, it goes off of it when I take my foot off. When I leave tuner mode, the loop mode activates and I can't get out of it unless I push several times on the button. What would you recommend me to do? Reset to factory settings? Ask a post-sale customer service? Thanks a lot for your answers.
×