Jump to content
Felverick

Bluetooth Dropping Fix

Recommended Posts

Hey everyone,

 

So I noticed a lot of ppl are complaining about bluetooth drops. Either right from the getgo or randomly they start dropping a fair bit. I was getting quite a few disconnects right out of the box every few minutes. My tablet sits right in the lip on the amp so it wasn't a proximity thing. I work in wireless hardware myself so I was pretty sure it was an interference issue which I don't see many troubleshooting. Seems most blame the amp and get it exchanged and have the same problem. 

 

Fact is most of us blast 2.4GHZ in our homes even if we don't know it. Bluetooth is on 2.4 so you end up with the potential to have the devices interfering with each other. In a perfect world either the amp or the router would change channels but the more DB your router is putting out the more bleed you'll get into the other spectrums. I have a pretty high powered router so I disabled the 2.4GHZ network from it and now I get no drops at all. Mine will dual broadcast on 5GHZ which seems to work fine but it could also be worth disabling that if you keep getting drops. From there you could experiment with locking the router to different channels. 

Share this post


Link to post
Share on other sites

This is interesting, my router isn't all that far away from my amp, when I'm streaming music it has short clips in the sound, very noticeable and annoying. having just bought this I'm worried..even cheap crappy Bluetooth speakers from Asda perform better than this.

 

I'll try your suggestion of turning off 2.4 ghz on my router, if I can then move my amp around. Watch this space.

Share this post


Link to post
Share on other sites

My router is a 2.4 ghz so I relocated the router to another room, turned anything off that used Bluetooth (computer mouse), and even tried disconnecting from the Internet while in the app thinking that maybe it's interference with other apps, or notifications coming through. Nothing is working the drops continue.

 

Let me know if you have any other ideas about the recent problems with the amplifi bluetooth connectivity issues.

 

:-(

Share this post


Link to post
Share on other sites

Sorry forgot to state that I also turned router off and still received the same dropping issue.

 

Thanks for the help though I appreciate it. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×