Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Can't download anything from Line6


Recommended Posts

I have been trying for a couple of weeks to download the most current Monkey. But the download gets to about 2% and stops. Sits there. Nothing more. Then eventually times out. So I tried to d/l the driver and Pod Farm2. Same problem. I had this same issue 2 or 3 years back. It eventually started working. I have tried on Chrome and IE. on Win7. I didn't have any problems earlier this year. Is anyone else having this problem lately? I don't have any problems downloading from any other sites. Just Line6. 

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...