Jump to content
Sign in to follow this  
Elvis_Parsley

Helix and JTV 59

Recommended Posts

I play a JTV 59 with a Helix and it seems that if you use the "multi' input as suggested in the manual, you have the sound of the Variax and the magnetic pickups at the same time. Please correct me if this is not the case. It seemed a little weird when I was playing a 12 string model through a clean setting and not getting a 12 string sound that I was used to through the 500x. After setting the input to just Variax all was well.

Share this post


Link to post
Share on other sites

There must be something wrong in your settings - Multi input does not include Variax Mags. I use a JTV-59 too with a Helix and I only get the Variax Mags if I specifically select that as the input.

 

Can you recheck things and post more detail if there's still an issue? Create a very simple preset to test - just one input, Multi, and one amp. Set the Variax model to something like Sitar which is easy to differentiate. Then change the input from Multi to Variax and then to Variax Mags. What's the result?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...