Jump to content
jeniczech

DT 50 112 Combo stops suddenly working

Recommended Posts

Hello there,

I have been having a very specific problem with my DT 50 112 combo. Basically, there are days when the amp works just fine without any problems. Then, all of the sudden you hear a single cracking sound similar to the one when changing channels, and then the amp stops working. What this means is that all lights are on and everything seems to be fine, except there is no output at all. I can be changing channels, topologies,  stand-by, turning all knobs left and right and still there is no output. The only thing I can hear is this unnatural humming noise coming out of the speaker. Sometimes, it is enough to turn the amp off and on and then it works again, sometimes I need to wait much longer. I've taken the amp to an authorized service place in my country, but they couldn't find the issue. They changed the valves tough, but that did not really help. Has anyone experienced this kind of issue before?

 

Here's a link to a video showing the problem: https://drive.google.com/open?id=0ByoVl89Vpu7sLWcteDRKbk1YNGs

 

Thanks.

 

Jan

Share this post


Link to post
Share on other sites

Looks like someone has already been in the unit.

How long since the valves were last replaced?

What brand and type of valves are in it?

 

If it pops and crackles, then goes quiet, then it's the valves or the main board.

It will need to be service by an authorized service center that knows the product

and has access to service information and me. It is not a self repair situation.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×