Jump to content
levantin

Weird DT25 issue

Recommended Posts

Hello forum gurus, thanks in advance for any feedback.

 

I have had a dt25 head for around 4 years that I enjoyed playing at home and with the band and have never had a serious issue with it. Recently I noticed it sound really weak, i.e. thin and not as much gain as it should have on voicing 4. I thought it must be the tubes so it went in to a tech for a tube change. The tech just called me to say the amp is outputting only 5 watts in class AB and high volume mode and that he can't really do anything about it. I thought about taking it in to the Line6 place in Amsterdam but it's quite a way away. 

 

Has anyone ever encountered this? Would a firmware update and/or factory reset do any good? Open to suggestions!

Share this post


Link to post
Share on other sites

Is the tech using the specified tubes and the specified bias?

Can't treat this like an all analog tube amp.

 

Is the tech a Line 6 authorized service tech? They will have the correct service info and technical support.

 

Is the volume control pulled out or pushed in?

The two positions have different volume levels. Each of the four voice topologies will normally have different

volume levels. Also make certain that the speakers are plugged into the correct amp outs for the speaker impedance being used.

 

Share this post


Link to post
Share on other sites

Got it, needs to be seen by an authorised tech. The nearest one is 150 km away so not likely to do that anytime soon. Thanks for the answer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×