Jump to content

Recommended Posts

Helo people. 


I really need your help. I tried to update my pod xt live firmware via USB...everything went well until I was asked to put it off and put it on again...the Boom! I got "Invalid Error Code 2". When I tried the update again, the button greyed out with a question mark.


I've tried everything I saw on this error to avail. Whoever has overcome this should please tell me what to do.


I've also tried midi cables, all that did was to do the update and go back to the error. 


Safe mode(using the first button under the display) does nothing.

The cond button shows "SRAM testing...successful"


...it only worked for 3days before I tried the update.


I did the update on win7 32 bit.latest version of monkey and latest version of USB drivers.


Pls help me.


If the upgrade does have issues, is there a way I downgrade back to ver2?

Share this post

Link to post
Share on other sites

Did you try restarting it with everything disconnected except the power cord? If that doesn't fix it, then: 

According to Line6:

PODxt Family Error Codes


If you are experiencing the following error codes in the display of your PODxt device:

Invalid Error Code 01
Invalid Error Code 02
Invalid Error Code 03
Invalid Error Code 04
Invalid Error Code 05
Invalid Error Code 06


please try the following:


Try the Edit Buffer Initialization with the following steps:


1. Turn off the POD
2. Turn on the POD while holding down the Save and Edit buttons simultaneously
3. The POD's LCD screen should display Init Edit Buffer
4. Push the Output mode button
5. Turn the Select / Select Page knob one click to the right
6. Turn the Effect Tweak / Change Value knob to the left or right adjusting the contrast.


If that does not help, please try re-installing the flash memory on the PODxt device using the instructions in the following link:


Pod xt Series: Factory Reset, Reflash, and Firmware Updates


If this does not solve the issue for you please locate your local Service Center for repair.

Share this post

Link to post
Share on other sites

Thanks bro. I've tried all of them and none worked. No service centre in my country and none is even close. I've also sent a support ticket since last week and I'm yet to get any reply.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now