Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Can't update on line 6 Monkey


Recommended Posts

I can't seem to be able to update 'Drivers;USB firmware;Flash Memory'

1. Drivers: I follow the installation guide. It confirms that it was successfully installed. It then continues to restart my MacBook but when line 6 monks opens it indicates that the drivers have not been installed.

2. USB Firmware: When I try update the USB firmware it says it can't connect to USB.

3. Flash Memory: when I update it goes through the whole process but nothing changes.


Can You please assist me?

Screenshot 2019-04-09 at 13.44.56.png

Screenshot 2019-04-09 at 13.45.15.png

Link to comment
Share on other sites

What version of Line 6 Monkey?  I just had it weird like that also.   I ended up trashing my current version of Monkey, downloaded the latest 1.78, installed it, and then it managed to install the drivers fine on my Mac.

Link to comment
Share on other sites

  • 3 weeks later...

I'm having the exact same issue. Furthermore, when I open HD500X Edit, it says that my computer doesn't recognize a POD HD 500X. I assume this is because I don't have the drivers installed, but as stated above, I have tried installing them about six times to no avail. Pretty frustrating. I submitted a ticket today, but if it's not a pretty quick fix, I'm thinking I'll just return this for something else.

Link to comment
Share on other sites

  • 2 months later...


Hi there. After hours of researching how to solve this problem, this is what I came up with that worked for me.

I'm a MAC user and have only have High Sierra 10.13.3 because that's as far as my current computer will update before running into issues. I'm not a computer whizz, just your average gear head that keeps running into software problems.


Here's what's happening with the Line 6 firmware installs. High Sierra is stopping Line 6 completing the installs because it's security setting is not recognizing and allowing Line 6 to have access to the system. Going to your system preferences and allowing Line 6 to install is not working for some reason!! So, here's what I ended up doing.


Open Line 6 Monkey and click the firmware update you want to install before you actually start downloading the firmware, open system preferences on your mac and click on security and privacy then the general tab. Make sure you can see both the Line 6 monkey and the system preferences at the same time and have instant access to both, I.E. next to each other on the same screen.

Unlock security and privacy by clicking on the padlock and entering your password when asked

Start to download the firmware update in Line 6 Monkey. You should get a message in system preferences, security and privacy stating that Line 6 is not recognized and a button that says allow. Click the allow button, the unrecognized message will remain on the screen. Carry on following the download instructions in Line 6 Money and carry on clicking the allow button in security and privacy at each step of the download. Eventually Line 6 Monkey will let you know that the computer will need to restart in order for the installation to be completed. Hit continue and the security and privacy allow button again.

The unrecognized message should disappear this time and the computer should restart. Once you computer had restarted, open Line 6 Monkey and all your firmware should be up to date and Monkey, Editor and workbench should be seeing and communicating with you Line 6 unit.


I will add that out of sheer desperation,  before I did this I fully uninstalled all my Line 6 software on my computer. I don't know if this made a difference, i don't think it did.

Do me a favor!! if this works for you please pass it on and help our fellow tech sufferers out.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...
On 7/20/2019 at 3:10 PM, AMGoddard said:

Just experienced the same issue on Windows 10 but thanks to Stubags' comments about security settings on the Mac I tried running it on the PC as administrator and it works fine.



Link to comment
Share on other sites

  • 8 months later...
  • 3 years later...
  • 2 weeks later...

It happens from time to time and is usually a change on the OS's permissions (like from an update). I had this recently on my Mac too. What worked for me is to close Monkey, unplug USB, plug back in, then run the License Manager (which resets some file behind the scenes in the OS), and then run Monkey again. This cycle works on the Mac when this happens. As these are old apps, sometimes permissions behind the scenes changes and some file the old app needs gets removed.


Try that cycle on your Windows OS and see if that works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...