Jump to content
A19suburban96

Spider V60 no sound out of amplifier

Recommended Posts

Like the title says I’m getting no sound out of my Spider V60 amplifier. I usually use the G10 relay which is fully charged. I’ve tried using the relay and a cable along with different guitars. The results are the same no sound. The amp turns on normally and the tap tuner feature works with both the relay and the cable so I know I’m getting a signal into the amp. I’ve had no other issues before now. The amplifier always stays in one place so it’s not like something could have come loose by moving it around. I’m at a loss with this. Any help would be appreciated. thanks

Share this post


Link to post
Share on other sites

After reading other threads with this issue, I gave the reset a try and it worked. I sure hope this isn’t going to be a regular occurrence. Guess I’ll start looking at other more stable amplifiers. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×