Please ensure Javascript is enabled for purposes of website accessibility Jump to content

HD500 - footswitchers start working only after several minutes


Recommended Posts

Hello everyone,

I have an issue with my POD HD500 unit. When I turn it on, footswitchers FS1-FS4 don't work right away. It's needed to keep the unit turned on for several minutes ("warm up") or reboot it several times or switch different channels to get footswitchers working. 

The things get worse because there is no any predictable behavior - sometimes only 1 switcher doesn't work but at the next time it might be 2 or 3 of them.

I tried to clean switchers contacts but it didn't help.

Also I tried to re-install the latest firmware and reset Flash using Right Arrow + Power On. It didn't help either.

It's reproducible on both factory and user presets (e.g. on A1: Son Of Plexi)



I would be very appreciate for any other suggestions how to get it fixed.

Link to comment
Share on other sites

If it is random and not isolated to one particular switch, I agree there is an internal fault.


You might try checking the ribbon cable from the footswitches to the mainboard. You might even be able to test by holding and lightly pressing components while with the othere hand switching and see if you can stablize it.

Link to comment
Share on other sites

The problem is resolved. The reason was in oxidation areas on the motherboard. I removed them using a contact cleaner and everything works as expected.

It might be due to the cold storage conditions especially in winter (I kept it near the window)

  • Upvote 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...