Jump to content

Sacco_Belmonte

Members
  • Content Count

    69
  • Joined

  • Last visited

Community Reputation

2 Neutral

About Sacco_Belmonte

  • Rank
    Just Startin'

Profile Information

  • Gender
    Not Telling
  • Registered Products
    1

Recent Profile Visitors

301 profile views
  1. Nevermind, I fixed it. Opening the transmitter was a breeze knowing there was a screw in the back of the sticker. Upon inspection, nothing was clearly bent, but I decided to lift the metal tongue that touches the pole because it might be a bit misaligned. By lifting I mean centering it around the pole by carefully wedging it up. It seems like the tongue was a bit misaligned, by a nanometer or so. I had one go at it, clearly something aligned because the unit now works as intended. Like brand new :D
  2. I bought a second hand G10 Seems like a slightly newer model, as the base LED is much brighter than my first unit. The transmitter it came with however, has a very flimsy activator pole (the small pole button near the TRS plug)...just a slight touch activates it and stays on, another tweak at it and turns off and so on...basically unreliable when it it comes to turning off. Does anyone knows why? Like a common cause and how to fix it? The unit seems ok, no signs of abuse or scratches. Maybe someone knock it while in the guitar, or dropped it, I don't know. Also, another side symptom of the loose bit is that sometimes the transmitter doesn't start charging. Is not too bad, I found its quirks, but would like to fix the transmitter.
  3. I should not heat up. Not something I noticed myself. Is it hot enough so you cannot keep your finger on it? If that's the case either the base or the transmitter is faulty.
  4. I just wrote it on the top, the forum deletes text after posting/replying. Forum admin: Please?
  5. Is because that specific guitar pickus up signal from the transmitter. You need an extension cable, I use a Y cable cause I happen to have that one, it's a 1 female TRS to 2 male TS.
  6. You can pair them both to the base so you don't need to plug them each time you switch. Still, you cannot use them both at the same time on the same base, the base only listens to one signal.
  7. No problem with my G10 whatsoever. I actually wanna buy another base, as I bought two transmitters, I don't wanna buy a kit with transmitter...I don't need a third one. So where can I buy a base alone?
  8. Got one of those mini magsafe cables. Best solution ever.
  9. Here fellas. Some Acoustic body IRs I did a while ago: (Stereo and Mono), I like them more than those around in the internet, as they are all mono. https://drive.google.com/open?id=1sw11vJPne33Oh9aVFctduwD3aB31esgn They work in my HeadRush and should work fine in your Helix. Works best if you use with an EQ and crank the highs up. Gitane DG300 Jumbo J200 Jazz Guitar Samick JZ4 Nylon Classical
  10. Stupid forum deleted what I wrote! (it was somewhat long) grrrr....whatever! Ah well...is the way these chips are. And that's that. Thanks for your answer.
  11. Question: Can one use reverb IRs in the Helix? such as some long verb out from a Bricasti unit in wav format? Thank you.
  12. Question: Can one use reverb IRs in the Helix? such as some long verb out from a Bricasti unit in wav format? Thank you.
  13. What happened?. I wrote quite some...grrrrr these forums. Anyway. I have two transmitters, both using the latest FW. If I leave either of them plugged in, even if they turn off after 4min they still discharge faster. Anyone else notices that?
×
×
  • Create New...