Jump to content

Cableaddict

Members
  • Posts

    11
  • Joined

  • Last visited

Everything posted by Cableaddict

  1. I've contacted two authorized repair centers, and even THEY can't get this information. - The same as what the OP reported. The system can't be repaired. The drivers can't be re-coned. No one can even tell me if my units are working according to spec, so I can't re-sell them as they might be defective. It's absolutely unbelievable.
  2. The "module" is the plate amp. AKA "amp module." It's standard industry terms. if you build or repair such things. Line 6 is using a stock Hypex plate amp, but they have their own custom DSP front end, to handle the "link" stuff. I thought about just buying new amps, but that's a bit expensive, with no guarantee I'd like the results. I'm sending a PM after this, but I have an important question: --------------------- Can you input a +4 signal into your L3S's, without flooring the limiter? This is what the specs say, and it's the industry standard, yet I can't get even close to this. They're also supposed to pull about 250 watts at 1/8th power (basically, that's right at their limit, with dance music pumping) yet mine barely pull 100 watts. (Because the limiter kicks in way too soon.) I'm hoping it had something to do with bad settings in the DSP, for the first year. (Mine are from 2012.) I've seen other users complain about the same problem, without ever getting a solution even from an authorized repair center. Again, I can't even get THIS information from the completely useless Line 6 tech support. Neither can either of the two authorized repair centers I talked with. It's unbelievable.
  3. Line 6 customer support says they have no information at all on the Stagesource line. Amazing. So, no, they are a complete waste of time, and this forum is my only hope.
  4. I doubt you'd have to do anything except plug a power cord into my module, connect your Md20 to it with a link cable, and then double click the FW updater. The module doesn;t have to be connected to speakers, surely. As for getting help from line 6, not a chance. I've called maybe 5- times, speaking with different techs. I can't even get them to tell me if the diesign changed after the first year, or if the modules are really supposed to limit at -10 dB. I will literally never buy another Line 6 product as long as I live, but in the meantime I have to try to solve this. So yes I'm still interested!
  5. I have two L3S subs, but no mixer. I bought them used, and they do not work well at all. The problem is clearly in the plate amp's dsp section, as the limiting comes on WAAAAY too soon. (I can't input more than a -12 dB signal!) As they are from 2012, I'm hoping that a FW update might improve things. I'd be willing to pay someone, who owns an M20d, a smallish fee to update these for me. I figure I could just ship you the amp modules themselves, plus the fee and enough to ship them back to me. I'm in NY State, so someone fairly close would be best. Thanks.
  6. I must say, this lack of response for even basic, but critically important questions, speaks volumes. I think I'll sell my subs, and never buy another line 6 product for the foreseeable futer. (ever.) This is really objectionable. Inexcusable.
  7. Well, I have PARTLY answered y own query. For any one needing a re-cone, and yes a driver can develop problems despite the amp's protection circuitry, I have found a source: Orban Audio can re-cone them, with the correct OEM parts, for $75 per driver. He'll also sell you the kit, sans glue, for $50, but the kits are not pre-assembled, so you have to really know what you're doing with that. Michael Orban: < mchlorban@gmail.com > ============================================ Still no source for replacement drivers, and I'm still DYING to know if Line 6 change the driver to another model, at some point. I can't believe that even Line 6 techs can't tell me this. It's beyond absurd.
  8. Does anyone know how to get re-cone kits, or at least replacement drivers for the L3S? Sure, they have built-in protection, but that can fail. One of my four 12" drivers (two subs, of course) is rattling at med-high volume, so.... Mine are from 2012, and have Celestion T5850A's. These are not a stock item, and Celestion refuses to tell me anything about them. (Unbelievable.) ----------------------- Also: Someone on another forum thought that Line 6 changed to a different driver at some point. Does anyone know if that's true?
  9. @Lightsnsirens - Sounds like you're OK for now, but in the future - I doubt you'll get much help from Line 6, as they seem to know virtually nothing about these speakers. ( ! ) From another post, we know that at least SOME L3s's used Hypex amp modules. Hypex used to make a "DS" series, which was a series of class D power modules for OEM use. That HAS to be it. So, you might try asking Hypex for advice, or the name of a tech that will actually have service manuals, etc. https://www.hypex.nl/plate-amplifiers/ -------------------------------- PLEASE report back hear if you learn anything useful. I have two L3S's and am very worried about reliability, etc. Oh, and FWIW - I've never heard of a quality piece of pro gear that got damaged from condensation. That's either a bad design flaw, or the cause was actually something else in the PS. It could simply be cheap, switching power supplies. (these plate amps appear far too small to have good torroidal trannies & big caps inside.)
  10. I have the exact same problem ! (Using JUST the subs, not the complete Stagesource system) Here's my situation: I wanted to replace my QSC KW181's, as I think they sound like garbage. The L3S looked, on paper, to be almost the perfect sub, but I was concerned about total output, since Line 6 doesn't give a spec. They are obviously tuned for good bass extension, not volume. That's what attracted me to them, but if not loud enough, then I can't use them. I read @DarrenHowell's post, above, and figured they must be at least REASONABLY loud. My plan was to buy a third, new, figuring that should be enough even for a med-sized. DJ party. No dealers had them in stock, so my only option for actually hearing them before buying was to buy used. I was "lucky" to find pair not far away, for a good price. I heard them at med volume, but did not have the ability to really push them, so I just took a chance and purchased them. Now I'm miserable. I would throw these things in the river, if I wasn't too broke to buy something else. I'm hoping these are either defective, or an early (bad) design, but I have no way to know, so how can I order yet another one? =============================================================================== THE SYMPTOMS: They sound great at low volume, (REALLY great) but the buzz & rattle horribly when they get near the limiting point. - And while the limiting point is supposed to be with a +4 input, these both start to limit at about -8 dBu. It's ridiculous. I just did a "DJ Dance" party for a group of less than 50 people, In a room just big enough for them all, with two subs in the center. - And I literally did not have enough bottom ! (And I'm not some homeboy DJ. I'm a life-long recoding engineer and rock musician. I don't try to melt the walls.) Additionally, they are supposed to pull 250 watts at 1/8th power. - that means typical program music at the maximum nominal level. Well, these pull peaks of 140 watts, with the limiters tripping. So, it seems likely that the limiters are coming on way too early. Another factor may be the cheap drivers. I realize that you don't need monster drivers when only pushing a few hundred watts into each one, but these things have cheap stamped baskets, and very narrow, stiff surrounds. Not very "pro" looking at all. More like Radio Shack quality. They could simply be flexing when pushed "hard." (except, it's not really hard at all.) And no, the coils aren't rubbing & the inductance is correct. The drivers appear to be OK. ---------------------------- Note that mine both have a 2012 date on the inside of the grills, so I'm wondering: ### DID LINE 6 CHANGE THE DESIGN AT SOME POINT? The OP's tech report says the Hypex amps are rated for 250 watts, but the current L3S spec indicates ~ 310 watts. Or maybe 155w RMS. Either way, it's different. --------------- ## As for the speakers: Can anyone tell me which drivers are n L3s's made within the last few years? (It would be good to know in case you ever need a replacement, or a recone kit) mine have Celestion T5850A.
  11. This thread is rather old, but I'm wondering if the OP was simply overload the input? - Never mind. I bought two of these subs after making this post, and I have the same problems. SEE MY NEXT POST:
×
×
  • Create New...