Jump to content

jonboyuk

Members
  • Content Count

    39
  • Joined

  • Last visited

Everything posted by jonboyuk

  1. Wow thank you, your advice is really useful indeed! There are so many options in Helix (different compressors/amps etc) it's quite overwhelming. But I'll take your advice and try what you've suggested re: palm muting amp settings :) Thanks so much.
  2. Actually I am using the neck, but I can't quite get that 'chuck'! I'll repost when I've tried rvroberts idea :)
  3. IYes, I'm aware of that! :) It's not so much the general fatness of the playing, it was more the clunkiness of the palm muted bits! Thanks for your suggestions on how to sort it though, I'll give them a go this evening!! :)
  4. Hey all - new Helix owner :) I don't know if this is the right place to ask, so apologies if not. I'm trying to create a patch for 'It's your thing - Isley Brothers' and I can't quite get the thick chucking (palm muted) sound at the end of each note in the verse. Does anyone know how I can achieve this? :) Many thanks!
  5. Ah that's fab, so it's just a minor update for HX Edit then! I hadn't noticed but thanks for the update Phil :)
  6. Snapshot bug discovered! I use the PowerCab (v2.0) and Helix (2.8) and the snapshot function will not change from 'speaker' to 'flat' or 'User IR' with a snapshot change. The only one that does work on the screen below is 'Remote', but that's it.
  7. That is very convenient! So in effect, the cab you now use is literally the physical PowerCab cab (by using LF Raw mode) and there's no emulation going on anywhere?
  8. Do you prefer the cabs in the PowerCab, or Helix?
  9. I've not experimented with LF Raw yet, but that essentially turns it into a 'normal' guitar amp, right? Thank you, I'll have a go with that. I suppose it's quicker with HX Edit :)
  10. Hi all, I've just acquired a Helix (very excited!), updated my PowerCab+ to 2.0 and the Helix to 2.8 and plugged them in. At the moment it all seems very complicated, but I think I'm getting there :) Am I right in saying that to use the default tones Helix, I need to set the output on the Helix just to FRFR mode? I'm guessing to use the built in PowerCab Cabs I need to manually go through all the presets and assign a Powercab cab, and remove the cab block from the Helix? If so - what a faff!
  11. Right you are! Thanks!! It's Logitech G Hub that's causing the BSOD. Infact, it does the same with my Helix. As a workaround, all you have to do is exit the app. I can continue using my Logitech hardware, but there's a conflict between the L6 driver and G Hub. Let the finger pointing begin! So who needs to fix this issue since they both work fine independently?
  12. Thanks Spikey, Yea I've tried 1.88 and 1.91 over multiple reinstalls. :( I'll wait and see if the update fixes it.
  13. Hi all Today I received my PowerCab Plus, and I love the thing. It made parting from my trusty old DT25 that little bit easier (especially when I lifted it!) Anyway I have only one issue with it, and it's that it causes my Win 10 PC to Blue Screen literally as soon as I plug it in. Although I've found a semi-work around, it's not good enough sadly. By using the default Windows drivers it seems to work in its most basic form - I can use 'Powercab Edit' and use it as a PC speaker. However, as soon as I try with an official driver (I tried 1.91 and 1.88), this is when It blue screens. It means I can't update the firmware from this machine and I can't use it in my DAW as an ASIO device. My guess is there is some kinda conflict because it works okay on my crappy little laptop. Has anyone had this before? Thanks Jon
  14. Some strange things are happening now. They might be perfectly normal, but as I bought it second hand I'm unsure of the intended manufacturer behaviour. 1. The thing is loud. I mean really really loud. In a gig practise situation, I would have the HD500X output set to max, the channel volume set to high on the amp, then the master volume at around half way. Now, if I have that I get serious volume/feedback from the amp. I've had to reduce everything quite a lot. So much so it's messed up a lot of my presets!! Sounds like a stupid comment, but I'm wondering if it's supposed to be quite that powerful (subjective I know). 2. If I roll my guitar volume down to 0% I get a quiet weird clicking/hum sound. That's even if I plug directly into the amp. It's not so much of an issue, but highlights something that might not be right. Any ideas? Thanks :)
  15. I've FINALLY had the tubes installed and biased. Apparently one of my tubes was massively underperforming and the other was taking all the load. The loaded one was giving a reading of 68mV whereas the other wasn't providing any voltage whatsoever. 2 new tubes biased at 25 mV +/- 3 mV and it's works BEAUTIFULLY. The amp sounds so much nicer - even better than when I bought it second hand. I suspect the guy who changed them was a bit clueless. Anyway, over the moon, so thanks for all your help earlier this year.
  16. Thank you for all that - very useful indeed. Therefore I've bought some paired EH EL84 (medium) and a 12AX7EH as suggested. So my next question is about changing them. I'm fully aware it's a risky process and don't particularly want to die! To change the tubes alone, is that something I can do without too much fuss/risk on the DT25? I appreciate biasing them is a little more tricky and needs more disassembly (and therefore more risk). Can I change them and have someone else bias them? Or can I change them and just see if it's any better off the bat and not bother biasing? Thanks!
  17. In the UK, all the valve shops I've looked at (6+) stock them, but they don't offer soft, medium, or hard. The only place I can see that is on musiciansfriend online. If they don't specify, is it therefore likely to be medium by default, or just potluck? EDIT*** Don't worry I spoke to the store and they said they can provide medium (something to do with Groove tube - I'm a bit clueless obviously!)
  18. That's really useful thank you - I don't doubt you one bit! Why does the official L6 guide suggest China 12AX7's for the DT25 and 12AX7EH for the DT50? I wonder what the logic is behind that - any idea? Also, do you think this is likely to sort the issue I've described above? And if I replaced them, would I need to bias them (or get them biased)? Bit of a newbie in that sense!
  19. Thanks and I'd agree - except that the Line 6 official knowledgebase says to specifically to use a Chinese-branded 12AX7 preamp tube on the DT25. EH are Russian! In fact the one in my amp at the moment is an EH (Russian) 12AX7, so should I be replacing it anyway?
  20. Just an update - I found these tubes. Would they be okay? I'm having most difficulty finding a Chinese branded 12AX7, but Tube Amp Doctor have them. Is it okay that they're not Electro Harmonix tubes? It's all so confusing! 1No. 12AX7 2No. EH EL84s Cheers, J
  21. Hi all, I bought my DT25 second hand on eBay a couple of years back. The seller said he'd replaced a couple of the tubes himself (I got the feeling he was a little clueless). Anyway, since having it it's been getting a bit - well - weird on me. Around 6 months ago, flipping the pentode -> triode switch causes notable hum. Knocking back to pentode resolved it so I've just used it in this mode. Around 1 month ago, flipping pentode -> triode makes the amp scream out with what sounds like feedback squeal (loudly). The volume control has no impact on the volume of said squeal. Pentode still works fine however. Is this likely to be a tube thing? I should also say that I'm clueless about tubes but have spent hours on these forums reading multiple old posts. I'm thinking if it is, I'll get them replaced. But, since I don't have the originals I'm not sure *exactly* what to replace them with. The knowledgebase says "Chinese-branded 12AX7 preamp tube (1) and Electro-Harmonix EL84 power tubes (2)." but which ones? ie EH 12AX7's? Or what? So confused. Can anyone point out which ones from say here or perhaps another UK based shop? Finally - on a separate note, I just upgraded my DT25 to the 2.0 firmware. I can't find any instructions on how to use the update! The only link on the L6 web site is now dead :( Thanks everyone :)
  22. Gig went well. No feedback? SO strange, there must have been something where we were practicing setting it off. Also note to self, not to position one's self directly next to the drummer, made it impossible to hear myself without having the amp set to 7/10! Oops!
  23. Thanks guys, sadly my amp is at the gig venue and I haven't got time to check it! But based on your advice, for now I'll take my second guitar and different jack cable! Fingers crossed! :)
  24. Hey Brad, It's a bit annoying because I have to mute before I play...is that normal? My previous SV 112 didn't do it at similar volumes and the feedback happens even if I move away from the amp! Secondly it's definitely the plastic because if I press the area where the plastic's vibrating the noise disappears completely!
×
×
  • Create New...