Jump to content
MetalBatman

Should update show progress on PC?

Recommended Posts

I have an Amplifi 150.

 

Plugged it. The 4 set tones played fine.

 

Installed App on my Android.

 

After trying to get tones, realized that it was saying my firmware needs updating.

 

I don't have any apple products.

 

My desktop runs Linux Mint.

 

My netpad runs Windows 7 Home Edition.

 

So it looks like if I dont have access to any apple device I can't do a BT upgrade and need to do a PC upgrade.

 

I found 2 USB cables that matched the description.

 

I Installed the Utility Software.

 

It didn't recognize the first cable.

 

It recognized the second.

 

I tried to update to that top latest version.

 

I held the two buttons and turned on the amp for update mode.

 

After 30 minutes of the blue circle going around and around saying it was installing (but no sign of progress on the progress bar) I unplugged to start again.

 

This time all the lights are on or flashing. I can't get it back to the state for update mode.

 

So I am trying another update again. 1hr 30min later still no sign of progress on the bar.

 

Should I see a progress bar if installing is really happening? Or is the system hanging?

 

It would be nice to actually be able to play on this amp I bought.

 

I don't know what to do to be honest.

Share this post


Link to post
Share on other sites

Yes, the PC Utility will show a progress bar. 

The Update via the Utility only takes a minute or so.

 

I would recommend trying another PC.

Once you have the latest firmware you can update via Bluetooth on Android.

Bluetooth updates take 30 to 45 minutes.

Share this post


Link to post
Share on other sites

Thanks for the quick reply. I have only 1 PC with Windows 7 Home edition. Its a Asus One netpad.

 

Can you think of any reasons why another PC is needed? It is a USB setting problem? OS problem?

Share this post


Link to post
Share on other sites

I've seen other users report having an issue with the PC Utility and Windows 7.

 

Perhaps a family member or friend has a pc or iOS device to try?

Share this post


Link to post
Share on other sites

We have been asking but have to wait till tomorrow.

 

In the meantime I can't even get the 4 tines back. If I told tone and tempo I still get 4 lights on power up, no popping sound. I tried restarting with with vol pressed and tone for a factory reset on power up. Still four lights on. Even if I find someone tomorrow with an iPhone, will I still be able to install in this condition?

Share this post


Link to post
Share on other sites

Update from a iPhone didn't work. Update from an iPad didn't work first time with latest, so I installed version 2 and got it to work.

 

I'm glad I don't have a brick anymore but an awesome combo for the features.

 

However this has to rate up there as one of the most needlessly complicated firmware upgrades ever. Hopefully as long as I don't reset the amp or crash it, I won't have to go through these summersaults again.

 

Anyhow, thanks. Works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...