Jump to content
royswan

Patch Switching Screech

Recommended Posts

I recently had my 10yr old XT Pro die the day before a gig.  So I ran out and bought an Amplifi FX 100 because I already have a TT in my studio and love it.

 

However, when I set up my banks for live performance, I typically have 2 clean patches and 2 dirty, hi-gain, patches (for solos) in each bank.  When switching from the hi-gain sounds to the clean sounds, I got this loud screech, like a 1950's ray gun, that would be completely unacceptable at a gig.  It just lasts for a second, in between the two patches, but a deal breaker.  

 

I then listened closely to my TT and heard the same sound, just much softer, when going from a hi-gain patch to a low gain clean patch...

 

So, is this just a part of the Amplifi circuits...  I noticed that in all 25 preset banks, they do not mix hi and low gain patches  ... except in one bank....  but in real life, that's exactly what I think most of us need.

 

Any ideas..? I returned mine that day, but would love to buy it back if there is some type of guideline on patch construction to avoid this.  Mine also lost Bluetooth constantly with my iPad, but was fine for my crummy Android.  Go figure... And yes, I did the Upgrade first thing?

 

Anyone else have this problem with the FX 100 or Firehawk?

 

Share this post


Link to post
Share on other sites

It's likely a difference in time based effects synching to the next patch.

Not a perfect solution, but you could roll off the volume either on your guitar or the FX100's Vol pedal right before switching.

Share this post


Link to post
Share on other sites

Right, but other pedals (like POD XT or X3) don't require such in -the-moment effort and have been "seperation" between patches.   Love the whole Amplifi line, but apparently not for live gigging  IMHO.  You could save me some time....Does Firehawk have the same issue?  Then I'll get an HD500... 

Share this post


Link to post
Share on other sites

Not sure, I haven't tried one yet.

 

But I do wonder if it is something that can be corrected in a future firmware update.

Share this post


Link to post
Share on other sites

I just bought a Firehawk and yes it does have the same issue. I've only had it happen with one patch though. Whenever I switch to or from that tone I get the short screech. I just selected a similar tone that doesn't have the issue instead, but hopefully this won't be a recurring thing. 

Share this post


Link to post
Share on other sites

Thanks.  I would love to buy a Firehawk, but need to know that you can switch between hi gain patches and those with time-based effects.  Please keep me posted....Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×