Jump to content

Updated but no Android


Recommended Posts

Hi there,

well, I borrowed an iPad from a friend, because update over the third (!) PC failed. 

Surprise- update worked. It only took around an hour.

Amplify on iPad told me- it is commected and Amplify 75 has the newest firmware.

Made a factory reset -> no problem, all the same.


Tried to connect via bluetooth from my Android device- ok, connection established.

But Amplify Remote App says the Amplify device found has an old firmware and needs to be updated ????


Any suggestion, why I still cant use Android? (or where to get an old iPad for free?)



Link to comment
Share on other sites

  • 4 months later...

with me is the same thing ....i can´t connect the amplifi 75 ( v.2.50 ) with a tablet or a phone samsung, Android ( 4:42 ) .

I can hear the Amplifi , mp3 coming from the tablet , but not AMPremote not recognize the Amplifi 75 .

The AMPLIFIremote menu below " voice search " appears " Buy Now " instead of " Amplifi CONNECTED "

I did all updates ( amplifications and Android ) , but I can not connect.

Can sombody help me, please?

thank you



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...