Jump to content
Sign in to follow this  
mfigueroa1111

My Line 6 Pod Pro Won't Power Up!

Recommended Posts

Hello ya'll, I recently purchased a POD Pro on ebay and when it arrived it wouldn't power on(it still hasn't). The seller is a store with 100% positive feedback on ebay, so when they described the POD as "working perfectly" I believe them. I know for a fact that it had a rough journey here because the box was pretty darn bruised and beaten. Can any one of you tell me what might be wrong with it? 

  • Downvote 1

Share this post


Link to post
Share on other sites

No way of knowing without someone techie looking at it. Might be as simple as a fuse or as complex as the whole board is fried. As you bought it on eBay I would first contact the seller and see what they say. If you find no quick solution I would ask for a refund and send it back sooner rather than later.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...