Jump to content
boynigel

Helix display screen glitching/picture noise

Recommended Posts

two hours out of the box and i'm getting strange picutre noise/distortion...whatever you want to call it, when i edit effects parameters (see pic).  anyone else encounter this issue?  it also did it during powering up.  very discouraging after waiting so long only to do this right out of the box.  firmware version 1.0.0

post-663037-0-95677200-1445914047_thumb.jpg

Share this post


Link to post
Share on other sites

two hours out of the box and i'm getting strange picutre noise/distortion...whatever you want to call it, when i edit effects parameters (see pic).  anyone else encounter this issue?  it also did it during powering up.  very discouraging after waiting so long only to do this right out of the box.  firmware version 1.0.0

There's been two firmware updates, 1.02.2 being the current one. Anytime I have issue with a device I always update to the most current SW.

 

Hope this helps,

 

mcoffey

Share this post


Link to post
Share on other sites

that was my go-to plan but my computer's OS is too old to run the monkey updater.  can you say, "stuck"?  i'd feel better if someone experienced this, updated, and the problem went away.  i should mention that after experiencing this problem, even after rebooting, i went out of the house for an hour to do some things and when i came back i restarted it and played with it for about 45 minutes and couldn't get the screen to glitch.  that's good and all, but i don't have confidence in it at this point.

Share this post


Link to post
Share on other sites

that was my go-to plan but my computer's OS is too old to run the monkey updater.  can you say, "stuck"?  i'd feel better if someone experienced this, updated, and the problem went away.  i should mention that after experiencing this problem, even after rebooting, i went out of the house for an hour to do some things and when i came back i restarted it and played with it for about 45 minutes and couldn't get the screen to glitch.  that's good and all, but i don't have confidence in it at this point.

Firstly, you don't want to use Monkey to update it. There is a new updater.

 

Secondly, you probably really should put a new OS on your computer as you'll probably want to take advantage of updates.

Share this post


Link to post
Share on other sites

Firstly, you don't want to use Monkey to update it. There is a new updater.

 

Secondly, you probably really should put a new OS on your computer as you'll probably want to take advantage of updates.

right, i get that.  my problem is that an update would force me in to updating my entire pro tools rig which runs rock-solid on its current version.  i've got another computer in the house that's running a newer version than OS 10.6.8.  hopefully the line 6 software will install on the OS it is currently running.  i tried the Line 6 Helix editor (i believe that's what it's called).  is that the one i'll be looking for or is it something else.  will try again after work today.

Share this post


Link to post
Share on other sites

that was my go-to plan but my computer's OS is too old to run the monkey updater.  can you say, "stuck"?  i'd feel better if someone experienced this, updated, and the problem went away.  i should mention that after experiencing this problem, even after rebooting, i went out of the house for an hour to do some things and when i came back i restarted it and played with it for about 45 minutes and couldn't get the screen to glitch.  that's good and all, but i don't have confidence in it at this point.

 

I've experienced this problem, but firmware v1.02.2 seems to have fixed it. So you can rest easy knowing it's only a software problem.

Share this post


Link to post
Share on other sites

right, i get that.  my problem is that an update would force me in to updating my entire pro tools rig which runs rock-solid on its current version.  i've got another computer in the house that's running a newer version than OS 10.6.8.  hopefully the line 6 software will install on the OS it is currently running.  i tried the Line 6 Helix editor (i believe that's what it's called).  is that the one i'll be looking for or is it something else.  will try again after work today.

The Line 6 editor is the program that you use to backup your preset info to your computer. You need to go to the download section and download the Line 6 Updater program. This is the program you use to update the Helix.

Share this post


Link to post
Share on other sites

OP here. I neglected to mention that I bought this from a dealer on ebay who assured me I’d be getting a brand new, factory sealed Helix. However when I finally received it, the factory seal had indeed been broken and the power cord was not secured in the box, allowing it to bounce around across the top of the unit while in transit from coast to coast. Keep in mind that the (bagged) heavy gauged power cable twist-tied together has the mass and weight of the average stompbox. Initially i was willing to look past all of this because the unit appeared to be working just fine…until the screen started glitching on me as described above. Now I’m thinking my unit was a return due to the screen glitching and possibly even something else that hasn’t reared its ugly head yet to me. I will admit that although the factory seal was broken, the unit was immaculate- not a fingerprint or scratch on it, but I’m always thinking in terms of the straw that broke the camel’s back in terms of the power cable getting bounced around over the knobs while in transit for 3K miles. Now I’m faced w/the conundrum- do I return it for a refund, or am I over-reacting and just need to try the firmware update as a forum member suggested earlier? A penny for you thoughts.

Share this post


Link to post
Share on other sites

Hey OP

Lol jk I've seen ya post before, kinda remember the name.

 

Ok I'm running 1.00.0 firmware same as you and I had screen glitch a little. Try a reset, seemed to help for me.

 

My 2nd bug is that after running through a bunch of pre sets or changing them my helix will put out a little distortion.

A simple power on an off seem to fix this.

 

I'm waiting for the big fix before I update. This little stuff I can handle.

 

Use the reset the clears out the most, what ever does a total system reset will be the one you want.

 

Hope this helps, it worked for me

Share this post


Link to post
Share on other sites

My helix was a brand new sealed in plastic and many boxes. And I still had a problem such as yours.

Reset works like a champ.

 

I think hold down last two buttons on bottom ( far right) as you turn helix on.

I used two just one step over

Share this post


Link to post
Share on other sites

OP here. I neglected to mention that I bought this from a dealer on ebay who assured me I’d be getting a brand new, factory sealed Helix. However when I finally received it, the factory seal had indeed been broken and the power cord was not secured in the box, allowing it to bounce around across the top of the unit while in transit from coast to coast. Keep in mind that the (bagged) heavy gauged power cable twist-tied together has the mass and weight of the average stompbox. Initially i was willing to look past all of this because the unit appeared to be working just fine…until the screen started glitching on me as described above.

That particular glitch is indeed a bug that has been fixed with one of the recent firmware updates (forget which one—it should be in the release notes).

 

The very first batch of Helices have all been opened up—We had an army of dudes who installed the latest firmware (well, it was new at the time) and USB flash drives. So yes, it's quite possible that the unit may have appeared to have been opened; we had a day to update many, many units, so perhaps a cable didn't get re-wrapped as tightly as it could've.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...