Jump to content

Amplifi 75 stuck in update mode

Recommended Posts



Not too much of a techie here.. Soo a few weeks ago my amplifi 75 stopped working and all the lights started flashing.. I figured out this meant it needed to be updated, so that's what i tried. At first, everytime I updated it (tried it with and w/o putting it in update mode) it worked for a couple of minutes up to an hour or so, but then it'd give out this loud continuous beep and it'd revert back into all lights flashing and nothing else working.. now, everytime I try to reset/update it nothing happens. I tried updating it both with my ipad and laptop (windows 10, latest updater installed).. Anyone who has any idea how to fix this??? Getting pretty desperate right now.


Thanks :)


Share this post

Link to post
Share on other sites

Hi Douwe,



I would try downloading the updated firmware file from the Line 6 Updater. Then install the update "from file". Its all within the interface making this quick and easy.


I would recommend the Factory reset (While holding the master volume and tone button, power on) > Update mode > install update + follow post update instructions. 


Please let us know if this does/doesn't help.



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...