Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Is reverse delay broken?


Recommended Posts

I created a tone today with some reverse delay on it and I'm getting a crackle/popping sound on the repeats and it's very audible

I tried moving the delay around in the chain and turning other effects off, lowering volumes etc but I can't get rid of it

Is anybody else noticing this?


Any help will be appreciated

I uploaded the tone to the cloud, it's called "millionaire clean"

If anybody gets a chance to try it out you really only have to ring out any note to hear it

I'd be interested to know if it's just me, I mean it could be my gear or something

I'm using headphones to monitor the sound





Link to comment
Share on other sites



I did serveral tests.


I have tested the reverse delay on my FH with my existing tones : nothing special.

I have tested the reverse delay on my amplify (without the FH) : it sounds the same


I have downloaded your 2 tones (millionaire). And they seem "normal".


No idea at that stage.


Did you try to change the tempo ?

Link to comment
Share on other sites

OK thanks a lot for your help , it must be something at my end causing the crackle then

And no I didn't change the tempo now that I think about it that's probably one of the few things I didn't try, I didn't try it through my speaker either, only headphones because it was late at night

Link to comment
Share on other sites

  • 10 months later...

Looks like this is a post from a while back, but I've searched and can find no other posts referencing this.

I have noticed the exact same issue with reverse delay. At each repeat of the delay cycle, there is a definite "click". Just like OP, I have tried moving the delay to different points in the chain, changing the mix parameter, note/time, and feedback, and it is always there (changing the time parameter just changes how often the click happens). Just like OP, I can duplicate this every time just by playing a chord that sustains longer than the delay time (to really make it obvious, do a volume swell).

To further troubleshoot I plugged in an old Boss DD-6 into the FX loop on the Firehawk and set the DD-6 up in Reverse mode and there is no click - the reverse delay works just like I think it should.

Firmware version is 1.20.00. I am also using Headphones to monitor sound. I'd really like to find a fix for the problem.

Anyone out there have the same issue?

Link to comment
Share on other sites

Yeah I am still yet to find a fix, also noticed it on the stereo delay more recently while recording through the USB except it seems more sporadic like there's no pattern to when the click happens, pretty frustrating to be honest and the first time I've had a serious problem with this pedal, we didn't notice the clicks until mix down so I now have to record everything again and add the delay later with a plugin

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...