Jump to content
Expat1000

Can't get clean sound on new Spider Classic 15

Recommended Posts

Hi, 

 

I just started playing around with my new AMP. Even after a reset, a power off/on, with FX both off, Drive turned full left, there are still a lot of FX in Clean mode. And the TAP LED is flashing! Why? FX are both off - why would the LED flash? But the main issue is I can't get a clean sound. Also, I tried saving these settings (no FX, etc) to another profile - the lights flash but the profile sound does not change. I'm pretty sure out of the box the sound was clean on CLEAN profile but no longer, and again, I reset to factory but it is still not clean.

 

My guitar is an Epi Les Paul Studio - nothing special about it and does not exhibit this behavior with other amps. Help, please!

Share this post


Link to post
Share on other sites

I had the exact same problem. I started playing around with the settings then I could not get it to reset by holding the Clean channel when powering up. 

 

My guitar sounded like crap. I couldn't get it tuned properly.

 

Here is what I found. First I powered the amp off. Then I turned all the controls except main volume to zero. Next I turned the special effects all the way up. I held the Clean channel button down while powering up. After the lights flashed, I turned the special effects knobs to zero and I got it to turn off all delays and the TAP LED stopped flashing. I was able to re-tune and got the greatest most mellow sound I had ever got from a guitar.

 

After I finished practicing, I tried the other three channels with my foot switch. Then I tried the Clean channel and the special effects came back.

 

Next I will try the procedure to turn them off I described above and try to save that setting by holding the Clean channel button down like it says in the manual.

 

I can't really find any videos on how to set up the Spider Classic 15, just demos showing off certain sounds.

 

Please let me know if you find anything further. 

Share this post


Link to post
Share on other sites

I had the exact same problem. I started playing around with the settings then I could not get it to reset by holding the Clean channel when powering up. 

 

My guitar sounded like crap. I couldn't get it tuned properly.

 

Here is what I found. First I powered the amp off. Then I turned all the controls except main volume to zero. Next I turned the special effects all the way up. I held the Clean channel button down while powering up. After the lights flashed, I turned the special effects knobs to zero and I got it to turn off all delays and the TAP LED stopped flashing. I was able to re-tune and got the greatest most mellow sound I had ever got from a guitar.

 

After I finished practicing, I tried the other three channels with my foot switch. Then I tried the Clean channel and the special effects came back.

 

Next I will try the procedure to turn them off I described above and try to save that setting by holding the Clean channel button down like it says in the manual.

 

I can't really find any videos on how to set up the Spider Classic 15, just demos showing off certain sounds.

 

Please let me know if you find anything further. 

 

 

Hi, 

 

I just started playing around with my new AMP. Even after a reset, a power off/on, with FX both off, Drive turned full left, there are still a lot of FX in Clean mode. And the TAP LED is flashing! Why? FX are both off - why would the LED flash? But the main issue is I can't get a clean sound. Also, I tried saving these settings (no FX, etc) to another profile - the lights flash but the profile sound does not change. I'm pretty sure out of the box the sound was clean on CLEAN profile but no longer, and again, I reset to factory but it is still not clean.

 

My guitar is an Epi Les Paul Studio - nothing special about it and does not exhibit this behavior with other amps. Help, please!

 

The amp models don't just change the way the distortion and eq reacts,it also loads a factory preset and ignores the knobs,if you want Full knob control everytime you switch channels turn: smart fx a and b ,a tone ,drive and volume,and it goes into full knob control

Share this post


Link to post
Share on other sites

The amp models don't just change the way the distortion and eq reacts,it also loads a factory preset and ignores the knobs,if you want Full knob control everytime you switch channels turn: smart fx a and b ,a tone ,drive and volume,and it goes into full knob control

Thanks, L3apr. I understand that but it does not work on other than the clean channel. I think it may if you reset to factory first but I don't want to fuk with that right now, and that would mean resetting to factory every time you wanted to reprogram any model. If I tap Insane model, turn down every single knob to off, then set the bass, mid, treble to 5, give it a bit volume - there is still some distortion. Not like insane model, but definitely some echo and some other fx - not sure what. My feeling is the amp is not defective. There are too many people with the problem. I think the description of the amp's abilities to set custom model profiles are misleading. 

 

I am very curious if you or anyone can do the following: Set the clean model to your own custom model. Save it. Set any other model, say insane, to utterly clean as well and save it. Is the sound now clean on the insane model as well? Was it before the save? I don't have a foot switch. Can't see why that would affect it but nevertheless, try with and without. 

Share this post


Link to post
Share on other sites

I have a new Spider Classic as well.  It WAS clean for the first couple of weeks, but now every time I turn it on, I've got funky effects in clean mode.

 

Here's the solution (Through simple experimentation and logical process):

 

Turn effects knob A all the way up and then off.  Then turn effects knob B all the way up and then off.

 

Effects are now actually off.

 

Not sure why it works like that all of a sudden, but that's the simple solution.

 

 

I've noticed too lately that my volume knobs seem to have only 2 settings:  Off and Shake-The-World.  With nothing in between no matter how I set them.  I'm probably doing something wrong, but I can;t help but wonder if this is somehow connected to the effects issue.....

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×