Jump to content
dkourounis

Volume Spikes When Changing Effects

Recommended Posts

I recently bought a Spider IV 75W amplifier from my local Sam Ash. I know it was on the sales floor, which means a lot of people had been playing it. I'm not sure what the reason for my problem is though. What happens is each time I turn the effects knob (located all the way to the left of the amp) to any effect, the volume spikes so loud that I think it's going to blow my amplifier. I then have to turn the channel volume all the way down and then back up to the desired level. I have to do this every single time I change effects. Anybody know why? Do I have a busted amp and need to exchange it?

Share this post


Link to post
Share on other sites

Congratulations on your new amp!  First thing I would suggest is to read the manual for the amp, available here:  http://line6.com/support/manuals/

 

The control to the left is not an FX knob, it is for setting the amp-model for manual settings.   Is it possible you have the master volume control turned way up?

Share this post


Link to post
Share on other sites

I agree with toneman2121. This sounds like the amp model for each channel is save with the channel volume up really high. Save each channel with the channel volume at a more reasonable level. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...