Jump to content
Sign in to follow this  
schaper

Variax Acoustic Not Turning Off When Disconnecting The Cable

Recommended Posts

Hi, I recently switched to batteries when using my Variax Acostic 700. I assumed that the guitar should turn off when I disconnect the cable. Yet the green light stays on, and I assume the batteries are still draining. so I have to uncrew the back cover and disconnect the battery pack manually when I'm done playing. This is very frustrating... and it's not the supposed behavior, right? Any help is appreciated..

Share this post


Link to post
Share on other sites

Yeah, it should turn off when you unplug the cable. It could be something relatively simple like a loose connection or a faulty relay, but it's not expected behavior.

Share this post


Link to post
Share on other sites

Yes it should turn off when you unplug the 1/4 inch cable.  There is a switch in the jack that powers it up.  Maybe that switch is stuck closed.

Share this post


Link to post
Share on other sites

Thanks for the replies, guys, I've unscrewed the female jack assembly and there are three contacts (look like bent metal strips) around the place where jack plugs in. When I press the first one (the one closest to the entry point), the green light goes out. I guess this contact needs to be closed when the jack is out, thus turning the guitar off, and mine had become loose. Can anyone confirm that this is correct, and I'm not just short-circuiting my Variax? :) Really appreciate your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×