Jump to content
Sign in to follow this  
tudscamp

Mute All Button

Recommended Posts

Purchased the StageScape M20D Mixer. The Mute All Button is not doing anything. Any suggestions? The Mute Mics button works fine.

I am connected to 2 - L2M's and 2 - L3S's via L6 Link if that makes a difference.

Share this post


Link to post
Share on other sites

It dose not make any difference what you're hooked up to if the switch is not working, it is the M20D, I don't know if you have the new firmware or not but you could try loading the new firmware or if you do have the new firmware reload it, it is available at the top of the page in the forum

Share this post


Link to post
Share on other sites

The Mute All button is strictly hardware so it won't make any difference which firmware you are using. (That's why you don't see it on your iPad app.)

 

When you press the button in are you seeing the switch light up and then go off?

Share this post


Link to post
Share on other sites

I never followed up with you all. Sorry, life got really busy. Hopefully nobody else will have the same problem, but just in case. My m20 was in fact defective. The mute all button did not work. It lit up when pressed (a slow pulsing light) but nothing was muted. It was replaced at no charge and the new one works great. FYI, when you press the button, you hear a distinct relay click, and all outputs are silenced. The broken one did not do that.

Anyway, all's well that ends well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×