Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Helix Native in Logic - worked now doesn't


Recommended Posts

So downloaded the trial to test it out

Looking for a quick fix while my amp goes in for repair.

Like the helix platform, had a rack, now use the HX Effects with my amp so thought native would work a treat.


Downloaded the trail to try it out. Created a bunch of patches and all was good with the world. Was originally thinking Neural but have played around with the Plini plugin Native was stacking up well.


Open a logic project tonight which had worked fine before (as described above) and it simply would not open. Eventually got it to open by turning all the plugins off re saved it and then it opened but the Native inserts that had worked perfectly well before would simply crash Logic the minute I tried to open or move the plugins.


Now I have a pretty ancient Mac and I'd happily concede that that was probably the issue had it not been for the fact that it had originally worked perfectly but now no good.


So any ideas why this should suddenly happen? I'm not going to be blowing proper money on this if it's just not going to function.


Thanks in advance



Link to comment
Share on other sites

There have been various posts on this forum from users like you having problems, especially with the demo. Its frustrating because things are working for most, but if its not its a train wreck. Line 6 has promised a fix to some users via support tickets, but it's not expected until "late spring."


The trial seems to have an overly-sensitive authorization process.  All I can suggest is to first make sure you have a working account at Line 6 (user name and password), as well as a working internet connection. Worst case you could trash all the Line 6 stuff that was installed (Application Support files, Component plug-in, etc) and try a reinstall. You can also read through the forum and see similar issues and possible solutions. 


I wish it was working for you, because it really is a nice plug-in when it works. Others may chime in with ideas .... good luck.


PS @benvigil offers a PITA workaround for Studio One that may also be usable for Logic ... here.

Link to comment
Share on other sites

On 5/20/2019 at 11:33 PM, neuk01642 said:


So any ideas why this should suddenly happen? I'm not going to be blowing proper money on this if it's just not going to function.



Hi Matt,


Sorry to hear that HXN has gone flakey on you. Line 6 aren’t doing a great job of inspiring customers with this sort of thing. There are many others on this forum with very similar complaints and should have been dealt with - fast!


The post from “soundog” above seems to address most of the things that I would have to say about this other than, the delay in getting this resolved is more than likely due to the fact that the Core routines of the operating system, across all the range of Helix products, are being brought into line. This should mean that the totally bug free updated version of Native will, hopefully, be released with the next firmware which has been promised by “late spring”. I imagine that will be before the end of June 2019.


I realise this does not particularly help with your situation, especially when there are so many HX Native users who have no issues. When it does work you have a full Helix brain without the hardware and it is impressive. It’s such a shame that Line 6 have not been able to put a little time aside to squash this bug, which seems to be a glitch in the “phone home” system.





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...