Jump to content
Sign in to follow this  
logicbdj

G10 wireless does not like piezo?

Recommended Posts

Hi... Even with the G10T pushed all the way into my Parker Dragonfly guitar, I get no signal from my piezo bridge pickups.  Is this typical?  No problem in using a cable, but I often blend my pickups and prefer the G10 system due to its clarity.  Any advice?

Share this post


Link to post
Share on other sites

Does your Parker have a TRS output jack? If so, then I imagine the piezo signal would come through on the ring connection. The G10T won't work with that, as it uses the ring for charging. You could try using the little TRS to TS adapter that came in the box. That would short the ring connection to the sleeve, so that may work.

Share this post


Link to post
Share on other sites

Thanks for the suggestion... that does work.  The only issue is a high-pitched hum that I can't eliminate. 

Share this post


Link to post
Share on other sites

On a related note, I have a transformer from Radio Shack (The Source) that's about 3-4 inches long... you plug a 1/4 inch and it's end is 1/4-inch.  When I use that in the guitar (along with the G10T) it works fine without any high-pitched hum.  And so, although a bit of a long thing sticking out, it works.

 

Yes, the guitar does have a TRS... it includes a cable that allows you to split the signal to two different amps.

Share this post


Link to post
Share on other sites

OK, that didn't work... sucked the life out of my tone.  The transmitter also doesn't work with one of my Ibanez guitars... the input is too deep for the G10T to fit (even with the adapter).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×