Jump to content
Sign in to follow this  
SolihullShredder

Stagesource And Hd500

Recommended Posts

I have just bought a stagesourceL2t  to pair with my HD500 using L6 link. It sounds fantastic but keeps defaulting to PA mode when I change patches from electric to acoustic sounds. I have updated all firmware -  anything I'm missing?

Share this post


Link to post
Share on other sites

The HD500 controls the L2t mode setting when connected via L6 Link, although the setting is not visible in the HD500 device or HD500 Edit. However, when you SAVE and HD500 preset it also saves the current mode setting of the connected Stagesource speaker. What you should do, for each preset, is manually set the L2t mode to your preference and then save the HD500 preset. This will store the setting in the HD500 and recall it each time you recall the preset.

Share this post


Link to post
Share on other sites

When I demo-ed it in the store it was with an HD500X and the patches changed automatically - is that normal? it was straight out of the box so presumably the 500X patches carry the data already? Just a thought but would it not be easier if this parameter was visible in HD500 Edit.

 

Off to try this now, love the stagesource sound quality.

Share this post


Link to post
Share on other sites

I've actually submited to ideascale the ideia of having the MODE shown and controlled from the POD...it would be much more practical!

 

The 500 and the 500x function in the same way in regards to the stagesource speakers, so you just have to manually select the mode on the speaker and then save it on the POD...you should be running the latest firmware on the pod, which is 2.2 in order to do so!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×