Jump to content
Sign in to follow this  
brue58ski

Helix JTV Variax tone parameter issue even after 2.9 update

Recommended Posts

This is a variation of an old issue. I keep waiting for an update to correct it. After updating my Helix to 2.9, I created 11 new presets, each with the Variax's tone knob saved at 10, 9, 8, 7, etc. to Don't Force. When I go from one patch with the tone knob at one setting to different patch with a different setting, the tone knob's position remains the same as the previous patches tone setting. For example if I go from a patch with the tone knob at 10 to patch with the tone knob at 1, it stays on 10 even though the Helix Editor indicates the tone knob is at 1. HOWEVER, if I select the patch with the tone knob at 1 again (either from the Helix or the HX Edit) it then will switch the Variax to the saved tone knob position. If the tone knob is saved as Don't force it goes to whatever position the tone knob on the guitar is at. So that does seem to work. This same type of thing appeared to be happening with the Volume knob before as well but seems to be corrected. So, for now, if I have a saved tone knob setting, I have to hit the patch switch TWICE for it to actually switch the tone knob setting on my JTV Variax to the saved setting. Has anyone come across this phenomenon? Apparently it's not an issue with Snapshots. Only going from one preset to another.

Share this post


Link to post
Share on other sites
On 4/23/2020 at 8:08 PM, brue58ski said:

This is a variation of an old issue. I keep waiting for an update to correct it. After updating my Helix to 2.9, I created 11 new presets, each with the Variax's tone knob saved at 10, 9, 8, 7, etc. to Don't Force. When I go from one patch with the tone knob at one setting to different patch with a different setting, the tone knob's position remains the same as the previous patches tone setting. For example if I go from a patch with the tone knob at 10 to patch with the tone knob at 1, it stays on 10 even though the Helix Editor indicates the tone knob is at 1. HOWEVER, if I select the patch with the tone knob at 1 again (either from the Helix or the HX Edit) it then will switch the Variax to the saved tone knob position. If the tone knob is saved as Don't force it goes to whatever position the tone knob on the guitar is at. So that does seem to work. This same type of thing appeared to be happening with the Volume knob before as well but seems to be corrected. So, for now, if I have a saved tone knob setting, I have to hit the patch switch TWICE for it to actually switch the tone knob setting on my JTV Variax to the saved setting. Has anyone come across this phenomenon? Apparently it's not an issue with Snapshots. Only going from one preset to another.

 

Since upgrading to 2.90+  (currently on 2.92), I have two presets that I need to hit twice before they'll work.  So It may not be related to the tone knob as much as related to activating the preset.  My guess is this that issue.  The double-select issue.  Try adding a different amp or effect to one of the presets and see if you need to select the preset twice for the new effect or amp to also activate.  One thing I'm going to try later today is a factory reset and then a restore from backup to see if that resolves the double-press issue for the two patches I have.  I'll let you know if it works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...