Jump to content
billyhell2

Powercab Plus 212 Just Arrived - No Sound

Recommended Posts

I bit the big bullet and got the 212. I had it plugged in and my Helix Stomp plugged in. There was not sound but after a minute the sound from the Stomp was coming through. I played a few chords and then started switching cabs and the sound went out. I am now not able to get any sound from the Powercab 212. 

Reinstall software? Reset? Send back?

Share this post


Link to post
Share on other sites

Hi billyhell2, 

 

Sorry for the late response, how is your Powercab 212 doing?

 

I recommend after power on, press and hold the home button and scroll down and initiate a factory reset. Also, at the end of this list shows the currently installed Firmware version. This should be Version 2.00.1  If your firmware is an older version than this, I recommend updating your unit via the Line 6 updater: https://line6.com/software/ 

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...