Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Firehawk 1500 power supply


Recommended Posts

On 7/4/2020 at 3:45 AM, PierM said:

This product is pretty much abandoned, as this section of the forums. Id suggest to open a ticket and probably send to assistance/repair...

I doubt I'm the only person that has had this issue. With this covid crap, I really doubt I'll get a reaction from LIne 6 about this. I can do electronics repair but have no reference as to what I'm searching for. I know there is a board that is a power supply only. If I can find a replacement for it I'll try that. I've replaced the relays on the board but it's the same result, relays click, LCD flashes and a transformer buzzes for a second then goes quiet.

Link to comment
Share on other sites

  • 2 years later...

My Firehawk 1500 hasn't been used for a couple of years. Switched on today and carried out update procedure (even though I think it already had the latest firmware). It worked for about 30 minutes while trying to connect properly with the app with FBV3 footswitch attached.

Suddenly switched itself off and won't power on. Reset procedure does nothing, everything is blank. Do I just have to raise a support ticket?

Did you get your power supply issue sorted and if so how did you achieve that?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...