Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Pod Go USB Audio Input Randomly Disconnects


Recommended Posts


When I have my Pod Go plugged into my PC via USB and I'm playing along with music via a browser (i.e. Multitracks or YouTube) my audio input will cut out at random intervals. I have my guitar plugged into the pedal, the USB plugged into my PC, and I'm using my headphones as an output through the pedal. I'll be playing along to a song or a backing track and all will be working well for 5-45 minutes, and then all of a sudden the audio will buffer and my Pod Go Edit will disconnect ("no device connected"). Sometimes restarting the pedal fixes the issue for a little while, and sometimes even restarting the Pod Go Edit software fixes the issue temporarily. Other times the backing track audio will come through for a few seconds and then cut out and the software will disconnect.


This started happening after I switched to a new PC not too long ago. My firmware and software are both up to date, and all of my PC drivers are too. I haven't been able to find anything about this issue on the internet, but perhaps I missed something. I have tried reinstalling the software to no avail. Another thing to note is that my guitar audio works flawlessly the whole time, so the sound disconnect is only between the PC input and my headphone output. 

Link to comment
Share on other sites

On 9/15/2023 at 3:33 PM, christian30 said:

I have the same problem ....


On 9/13/2023 at 8:55 PM, silverhead said:

Try not using the POD Go Edit program, just temporarily for troubleshooting. Play along to your backing tracks as normal. Do the dropouts still occur? The answer to that will inform next steps.

…. and your answer to the above…???

Link to comment
Share on other sites

On 9/16/2023 at 2:01 AM, Dadstatus said:

It did continue for me with the Pod Go Edit program open. What fixed my issue was plugging my Pod Go into a USB 2.0 slot instead of a USB 3.0, not sure why, but it seems to have solved the problem.

Glad it’s sorted out. Thanks for posting the solution; good for others to know.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...