Jump to content
Sign in to follow this  
Newsbusters

KB37 and Logic Pro X - some keys not working

Recommended Posts

I am using a Line6 KB37 together with Logic X 10.0.7 (OS X 10.9.4). The KB37 (newest drivers and firmware) is my audio in- and output and midi device. Everything works fine except two keys on the KB37 which are not triggering sound (e. g. as a software instrument). It's F3 and B3. Instead of triggering sound some weird movement on the faders are happening. I can trigger those two tones without a problem drawing them into piano roll. Also GarageBand has no problems at all triggering every tone on the KB37. It clearly seems to be a Logic Pro X problem. And my Roland FP-7 masterkeyboard (also connected via USB) triggers all midi notes correctly, too. It very much seems to be a midi-misunderstanding between the KB37 and Logic, but I have no idea where I can map the KB37 correctly. 

 

Any ideas how to solve this annoying problem are more than welcome.

 

Thanks,

 

Marc

Share this post


Link to post
Share on other sites

Can Line6 please respond to this post above, I am haveing the same problem with my KB37 keys not working. How can this be fixed????

 

Thanks

Andre

amagistr@hotmail.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×