Jump to content
Sign in to follow this  
jagzzzz

Slight delay/latency when using POD X3 through my PC

Recommended Posts

Hi everyone basically using my POD x3 I get a slight delay of less than a second or so making it so hard to use and no fun. I never had this problem on my old PC.

 

My POD x3 is plugged in through the left/right output on the POD via cable to the Black LINE IN on the back of my PC. Obviously my sound comes through my PC speakers making it easy to record.

 

I'm sure you guys have seen this many times but is it just simply my sound card isnt good enough, or pc is processing it slowly or is there another solution?

 

I was gonna purchase a UX1 but if this will still happen obviously I dont see the point.

 

Thanks for any help it will be much appreciated!

Share this post


Link to post
Share on other sites

all would be solved if you just plugged your computer speakers into the x3 and forgot all about your internal card.

set x3 as default soundcard in windows, and make sure the x3 output mode is set to match studio/direct

then all your computer sounds will come through the computer speakers (that are now connected to the x3)

Share this post


Link to post
Share on other sites

In windows I have no way of setting x3 as default soundcard. In sound settings all I have is set default for speakers/headphones - idt high def audio codec which is my soundcard i assume?

 

all would be solved if you just plugged your computer speakers into the x3 and forgot all about your internal card.

set x3 as default soundcard in windows, and make sure the x3 output mode is set to match studio/direct

then all your computer sounds will come through the computer speakers (that are now connected to the x3)

Share this post


Link to post
Share on other sites

well the x3 needs to be connected via USB and the drivers installed (run monkey)

then your pc should see the x3 as an option.

Share this post


Link to post
Share on other sites

well the x3 needs to be connected via USB and the drivers installed (run monkey)

then your pc should see the x3 as an option.

 

now pod is displayed in play and recording tabs in sound properties in windows. i set both to default but get no sound. but strangely the green bar still moves up and down as i play in the sound properties. but no sound?

Share this post


Link to post
Share on other sites

is the output set correctly? and speakers connected to the x3?

no no i've got it all wrong i was assuming i could connect pod to pc via the usb and that would be all that i needed. but obviously i'm missing a connection from my pod to my speakers directly. which isnt possible as my speakers just have generic connections to my pc through colored cables. very confused

Share this post


Link to post
Share on other sites

so basically i need some speakers for my pc which i can also connect to my pod. or at least speakers which have the correct connections to plug into my headphone jack on the pod.

Share this post


Link to post
Share on other sites

yes that's correct... you can use headphones to test.

in terms of connecting my pc speakers to my pod. a few questions. the speakers would connect to which bit of the x3? is this done via a cable i could get with speakers or would need to purchase seperatly and finally could i have my pod and pc connected to the speakers at the same time?

 

sorry for all the questions and complete cluelessness of me. thanks for all your replies TheRealZap

Share this post


Link to post
Share on other sites

the 1/4" left and right out would be ideal.. but you could connect to the headphone port. may require an adapter from your speakers...

but its common. you wouldnt need to be connected to both... all sounds would come out of the x3

 

in terms of connecting my pc speakers to my pod. a few questions. the speakers would connect to which bit of the x3? is this done via a cable i could get with speakers or would need to purchase seperatly and finally could i have my pod and pc connected to the speakers at the same time?

 

sorry for all the questions and complete cluelessness of me. thanks for all your replies TheRealZap

Share this post


Link to post
Share on other sites

the 1/4" left and right out would be ideal.. but you could connect to the headphone port. may require an adapter from your speakers...

but its common. you wouldnt need to be connected to both... all sounds would come out of the x3

so the dual 1/4" to stereo 1/8" that i currently have would go into my speakers from the pod. usb plugged in meaning sound from pc would go through pod to speakers. meaning as long as pod was connected i would get sound from pc and guitar at same time? i hope i am right lol

Share this post


Link to post
Share on other sites

Correct :)

thanks for your patience with that i finally understand. thanks again for your help and quick responses!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×