Jump to content

622 topics in this forum

    • 0 replies
    • 2,986 views
    • 0 replies
    • 10 views
    • 0 replies
    • 17 views
  1. POD X3 LIVE

    • 1 reply
    • 236 views
  2. Problem with pedal and sound output: POD X3 Live

    • 5 replies
    • 1,113 views
    • 0 replies
    • 158 views
    • 5 replies
    • 1,603 views
    • 0 replies
    • 172 views
    • 2 replies
    • 622 views
    • 0 replies
    • 199 views
    • 0 replies
    • 268 views
    • 0 replies
    • 244 views
    • 0 replies
    • 305 views
    • 1 reply
    • 427 views
  3. POD X3 with POD FARM2

    • 1 reply
    • 504 views
  4. Pedal x3 live sin sonido

    • 0 replies
    • 329 views
    • 9 replies
    • 906 views
    • 0 replies
    • 373 views
    • 1 reply
    • 357 views
    • 3 replies
    • 542 views
    • 0 replies
    • 382 views
    • 0 replies
    • 389 views
    • 2 replies
    • 531 views
    • 1 reply
    • 505 views
    • 0 replies
    • 421 views
    • 2 replies
    • 853 views
    • 2 replies
    • 411 views
  5. How do I edit sounds?

    • 1 reply
    • 441 views
    • 6 replies
    • 1,428 views
  6. Line6 X3 live adapter Issue.

    • 1 reply
    • 495 views
    • 36 replies
    • 11,238 views
  7. X3 LIVE Wah and volume Selection

    • 2 replies
    • 476 views
    • 0 replies
    • 426 views
    • 1 reply
    • 476 views
    • 2 replies
    • 1,342 views
    • 18 replies
    • 7,347 views
    • 0 replies
    • 409 views
    • 1 reply
    • 450 views
    • 0 replies
    • 452 views
    • 1 reply
    • 586 views
  8. UX1 registration problem

    • 0 replies
    • 499 views
    • 1 reply
    • 554 views
    • 0 replies
    • 602 views
    • 6 replies
    • 2,248 views
    • 1 reply
    • 900 views
  9. Pod X3 Footswitch

    • 1 reply
    • 658 views
  10. Pod X3 Live Keeps Rebooting

    • 29 replies
    • 5,128 views
    • 30 replies
    • 15,903 views
    • 6 replies
    • 5,174 views
    • 1 reply
    • 892 views
×