Jump to content

hausi_117

Members
  • Content Count

    5
  • Joined

  • Last visited

Everything posted by hausi_117

  1. hausi_117

    Helix long time professional use

    Hey there! so I wanted to ask, what are your experiences in the long run with the helix, especially in professional use/touring? Right now I am a Kemper + pedalboard player as well as the Boss GT 1000, but never got quite statisfied. But having tried the helix more recently I was very happy with the sounds I got as well as the flexibility. Since I am professionally gigging musician my question is: Did you have any major issues, freezing, parts breaking, errors during shows, total dropouts etc. I had a HX Stomp and a HX Effects, both times I had the bad luck of a faulty unit. Gear failure just must not happen for me. So what are the opinions on the helix of the touring musicians out here, since the helix has been out for a few years? (Sound, reliability, build quality) :)
  2. hausi_117

    Helix long time professional use

    Thanks your your respone, sounds great, do you have a stomp or a floor? yeah, I always keep a little preamp and cabsim in my pocket as a backup! Luckily never needes it but would get me through the gig.
  3. hausi_117

    Helix long time professional use

    The HX Stomp had broken outputs where I was just getting noise and the HX Effects had a faulty footswitch which caused the unit to freeze, but I am still not giving up on line6 since I hear so many great things! thanks a lot!
  4. hausi_117

    HX Stomp buzz after update to 2.71

    already tried that, it is still there, on all outputs, amp and speaker units. maybe its a deffective unit. I will return it.
  5. hausi_117

    HX Stomp buzz after update to 2.71

    so I recently got a hx stomp, tried it out, everything was working fine and it was dead silent, then I updated to the new firmware and all of a sudden got this buzz noise (its attachedto this post). it goes away after some time, but comes back. I also tried different power supplies and outlets , its always the same result, does anybody else have this problem, it seems like a software issue, since it was working fine before doing the update. hx stomp buzz.mp3
×