Jump to content

DimitriusK

Members
  • Content Count

    9
  • Joined

  • Last visited

Everything posted by DimitriusK

  1. DimitriusK

    Suddenly no sound coming out of my Helix

    I was rehearsing with my band and suddenly my Helix went silent (no sound coming out from the ¼’’ output). Tuner doesn’t respond either so I assume there is some kind of problem with the input. Tried to connect different guitars and various cables in order to make sure there was signal feed in the guitar input of the Helix. All features and menus seem to work fine. I can navigate through presets and settings. I created a support ticket and I am waiting for a reply. I also tried to reset the device and updated the firmware. Still no sound. Any ideas?
  2. DimitriusK

    Suddenly no sound coming out of my Helix

    My version of the manual unfortunately does not state anything about XLR outputs and phantom power. (see attached document) First thoughts was that line 6 found out about this defect later and instead of solving it they decided that it was cheaper to update the manual with a warning. I had the privilege of communicating with Frank Ritchotte regarding my problem who ensured me that “ Phantom power can’t cause damage it just makes the Helix sound like crap.â€
  3. DimitriusK

    Suddenly no sound coming out of my Helix

    Thank you very much. This makes sense!!
  4. DimitriusK

    Suddenly no sound coming out of my Helix

    Today I got an e-mail from Thomann explaining that the damage was caused by an applied voltage at the XLR output and that I am not entitled for a warranty repair. I often use my Helix without an amp as many users of amp simulators like Helix do. I plug it directly to the soundboard which sometimes sends 48v phantom power to cover the voltage needs of DI boxes, condencer microphones etc. Does anyone know if Helix is unable to handle the 48v phantom power at the XLR outputs? Can anyone provide me with more information about the voltage tolerance of the Helix outputs? Did anyone come across any article or review pointing out Helix’s inability to handle 48v phantom power voltage?
  5. DimitriusK

    Suddenly no sound coming out of my Helix

    The problem occurred in my case before the update to the latest firmware. I hopped that the 2.3 upgrade could fix this but I wasn’t lucky enough.
  6. DimitriusK

    Suddenly no sound coming out of my Helix

    Unfortunately I was not able to resolve this by myself. My Helix was sent as advised by Line 6’s helpdesk to the authorized dealer (Thomann in Germany) that I bought it from. It’s been a month since then and still no news …..
  7. DimitriusK

    Suddenly no sound coming out of my Helix

    I installed the latest firmware (2.30) and unfortunately the problem does not occur on specific presets. I also reset Helix to factory presets and globals but without any result.
  8. DimitriusK

    Suddenly no sound coming out of my Helix

    By the way…..while desperately experimenting with inputs and outputs I noticed that the left XLR output is made by Neutrik and the right is made by Amphenol. This seems a little bit strange. Has anyone else noticed mismatched parts on their Helix?
  9. DimitriusK

    Suddenly no sound coming out of my Helix

    Yes I tried plunging into the Aux in and the four return loops as well but with the same unfortunate result. Still there is no sound and tuner does not respond.
×