Jump to content
mrmykl

variax standard ghost pickups install

Recommended Posts

Hey, everyone, I have a Variax standard that I have purchased Graphtech Ghost pickups for to replace the Baggs it came with.   I've done this before on my trusty 300 (which I have gigged for ten years and rarely had a problem with...).  Problem is the pickups I bought look different.  Without thinking I immediately cut the wire on one to start stripping down the two wires (ground and signal) and it seems like the ground on this new pickup is only one strand of copper running just under the sheath.  Last time it was two (albeit very small) silver wires.  These are black and seemingly only separated at the tips for the Acoustiphonic system's fittings. So, question:

1.  Anybody even put Ghost pickups in a standard yet? Any words of wisdom, encouragement or warnings?  Or pictures of the install?

2. Did I just brick a pickup and now need to find an older set of the Ghost pickups that are silver wires?

3. Anybody figure out how to load 1.9 in a standard without a JTV motherboard?  Really love those acoustic sounds...thank you in advance for any help you can provide!

IMG_20190112_145806608.jpg

Edited by mrmykl
Added picture.

Share this post


Link to post
Share on other sites

Warning,... always read the directions first before opening anything else.

1) All Variax piezos come single wire, the casing is the chassis ground. Mounted correctly, and kept clean, should work fine.

2) Don't know yet.

3) No. All firmware goes on the main processor board and nowhere else. Standard requires v2.2 or higher.

It won't roll back to v1.90 program. Just tried one myself, it won't do it.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×