Jump to content
blubleez

POD UX2 No Meter Movement for Instrument... Please Help??? :(

Recommended Posts

Hey guys, I've read all the posts about POD UX2 in this forum, but nothing seems to help :( Please help me out ;( 

 

About two months ago my POD UX2 did not have any problem with its sound or signal.  

 

Now that I have spare time, I connect the device again, but no sound & no meter movement :( 

 

- I use POD Farm and Window 10 with my device

- The issue is not about my guitar--no active pickups, guitar knobs at full, working perfectly last week

- The output level and volume on Pod Farm are also not the problem

- The unit lit up, but showed no meter change whenever I played something on the guitar

- The screen (on Pod Farm) also shows no meter change as well

- I can hear other audio sounds (i.e. youtube) through the device, though

- The mixer input was on instruments, so no problem with the mixer

 

- Unfortunately I have no access to other amps, so I cannot tell if the problem lies on the guitar cable... hopefully if that's the case I would simply be able to change it out.

 

But is there any other possible issue that I might be overlooking? Please help! :( :( :(

Share this post


Link to post
Share on other sites

Is your ux still set up as your soundcard on your computers settings?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...