Jump to content
klasi

DT50 disconnected speaker and blown fuse

Recommended Posts

So I took a risk on a DT50 2x12 that wouldn't power up because the price was too good.  Hey, everything is repairable, right?

 

I checked the fuse at the plug-in and it was blown.  I have a replacement fuse on order.

 

AND I noticed that one of the speakers was disconnected in back.  I assume that the connection goes on the left tab.  Correct?

 

Also, I'm guessing that since one speaker was disconnected this would make the draw not 16 ohms but rather 8 ohms (the speaker out cable is coming from the 16 ohms jack).  Correct?

 

Is this a likely cause of blowing the fuse?  Could this have done more damage to the amp than just blowing the fuse?  I.e. the transformer and/or something else?

IMG_1262.jpg

IMG_1263.jpg

IMG_1264.jpg

Share this post


Link to post
Share on other sites

Hope it didn't damage the output transformer. Never power up an amp without a proper load on it.

It should be checked out by a Line 6 authorized service tech.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...