Jump to content
marmatkat

Powercab 112 Plus ~120Hz resonance?

Recommended Posts

Hi Everyone,

 

I'm liking my PC+ after a month of trying it out at home. (No practice or gigs due to COVID-19.) I've noticed that almost all my presets have a too-strong resonance around 120Hz. It's annoying and I wonder if this is how it is with the PC design. Again, I'm in a small-ish room, so maybe it's better on stage. I'm using the parametric eq to subtract between 4 and 8 db depending on the amp/cab. I'm using the PC+ in FRFR mode, modeling everything in my Helix LT.

 

Love to hear your thoughts!

Share this post


Link to post
Share on other sites

I'm having a similar issue, and it seems like it's something that didn't happen when the PC+ was new..maybe the high frequency driver has an issue? I was thinking of resetting the PC + back to factory, to see if that helps..maybe someone from Line 6 can jump in? I use to love the sound of  the Helix LT/PC+ combo, but now, I find myself playing it less and less because of this issue, and going back to my tube amps with the OX Box

Share this post


Link to post
Share on other sites

So, I opened a ticket with Line 6, and, I have to say, pretty unhappy with them,so far.

I did discover that there is an issue with the digital cable, the AES or Link cable they call it, in that when I unplug it from the Helix LT the issue seems to mitigate to a certain degree. Actually quite a bit. But it still has a weird mid-range boost that sounds like it's around 1 to 3 K, but definitely improved when I unhook the cable. Thinking it was the digital cable, I ordered another one, received it plugged it in, and... Same issue

I'm convinced there's something wrong with the power cab. I responded to the ticket I have open, and I'm waiting to hear back from Line 6. Unfortunately I bought this cabinet either is a B stock or used I can't remember because it was a year or two ago. So I probably have no options in regards to warranty. This cabinet has never been gigged, and never been out of my studio, and doesn't get used that much. This issue just all of a sudden appeared, not like happened after the cabinet was dropped or something of that nature. Pretty disappointed in this product at this point. I really loved it when I first got it it, sounded awesome, but now I can't even stand to listen to it when I plug the Helix LT into it. May end up selling this stuff and going in a different direction. Not happy with line 6 customer support either.

Share this post


Link to post
Share on other sites

Sorry to hear about your trouble, tdawgg :-/  That might be something different from mine. Good luck.

Share this post


Link to post
Share on other sites

I would be interested to hear about the resolution of this issue.  Please keep us posted.

Share this post


Link to post
Share on other sites

So, quick update. I had some back and forth with line 6 support, somebody named Pete. You really didn't offer up any solutions other than I would need to send the power cab in to get it repaired. But he couldn't even really offer a solution in that regard.

But, I am happy to report, the problem is solved!

I was connecting the power cab to the Helix LT via both an AES and XLR analog cable. apparently with the new update, all that's needed now is the AES cable. When I had both cables connected, it was causing some weird phasing issue.

With just the AES cable connected to the Helix LT, everything sounds fine! You can then go to the output section, and adjust all the parameters on the power cab, and assign speakers to each patch.

hopefully this will help someone else having the same issue, as Line 6 support really didn't offer very much support...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...